classification
Title: Tkinter ttk tests hang on linux
Type: behavior Stage: resolved
Components: Tkinter Versions: Python 3.3
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: asvetlov, lukasz.langa, r.david.murray, serhiy.storchaka, terry.reedy
Priority: Keywords:

Created on 2012-05-13 18:55 by asvetlov, last changed 2018-01-29 14:13 by asvetlov. This issue is now closed.

Messages (11)
msg160547 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2012-05-13 18:55
By default python doesn't run full test suite, but regrtest accepts -u parameter. The simplest way to reproduce is:

$ ./python -m test.regrtest -u gui test_ttk_guionly
msg160636 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-05-14 16:23
It does not hang for me on Gentoo.  When I run the test suite before a checkin, I use -uall, and I've never had test_ttk hang for me.  I did an 'hg pull; hg up' before running the command line you give below.
msg172630 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-10-11 10:31
> $ ./python -m test.regrtest -u gui test_ttk_guionly

For me (on 32-bit Ubuntu 10.04, Tk 8.5) it failed:

test test_ttk_guionly failed -- Traceback (most recent call last):
  File "/home/serhiy/py/cpython/Lib/tkinter/test/test_ttk/test_widgets.py", line 579, in test_tab_identifiers
    self.fail("Tab with text 'a' not found")
AssertionError: Tab with text 'a' not found
msg172631 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2012-10-11 11:03
For me it still fails. 
I use Ubuntu 12.04, 11.10 was failed also IIRC.
msg173787 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2012-10-25 18:18
Update: test_ttk_guionly hangs on Ubuntu with Unity.
It passed on Arch as well as on Ubuntu via xvfb-run.
msg173788 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2012-10-25 18:20
Fir Unity it hangs on Tcl_ConditionWait inside Tcl_DoOneEvent function.
msg173789 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-10-25 18:37
For me it passed with Openbox and Compiz, but fails with KWin.
msg248151 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2015-08-06 21:50
Andrew, is this still a problem with current Unity? Or with updated version of tk 8.5, or any version of 8.6?

Should we downgrade this from 'critical'?  After 3 years, it seems not to be ;-).
msg302988 - (view) Author: Łukasz Langa (lukasz.langa) * (Python committer) Date: 2017-09-25 23:06
Unsetting priority.
msg302993 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-09-26 00:05
A year or so ago, I asked people on python-list who could to run the gui tests on their linux boxes and report.  About 6 did and with one possible exception, and not that reported here, everyone reported success.  So, unless someone can report otherwise, I think this should be closed.

I think we should regularly ask the community to help with gui tests.
msg311138 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2018-01-29 14:13
Yes, everything works on Ubuntu 17.10

Closing the issue
History
Date User Action Args
2018-01-29 14:13:58asvetlovsetstatus: open -> closed
resolution: works for me
messages: + msg311138

stage: resolved
2017-09-26 00:05:40terry.reedysetmessages: + msg302993
2017-09-25 23:06:08lukasz.langasetpriority: critical ->
nosy: + lukasz.langa
messages: + msg302988

2015-08-06 21:50:16terry.reedysetnosy: + terry.reedy
messages: + msg248151
2012-10-25 18:37:36serhiy.storchakasetmessages: + msg173789
2012-10-25 18:20:17asvetlovsetmessages: + msg173788
2012-10-25 18:18:01asvetlovsetmessages: + msg173787
2012-10-11 11:03:48asvetlovsetmessages: + msg172631
2012-10-11 10:31:00serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg172630
2012-05-14 16:23:44r.david.murraysetnosy: + r.david.murray
messages: + msg160636
2012-05-13 18:55:42asvetlovcreate