classification
Title: document imp.load_dynamic()
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.2, Python 3.3
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: docs@python Nosy List: berker.peksag, brett.cannon, docs@python, eric.snow, pitrou, r.david.murray, scoder
Priority: normal Keywords:

Created on 2012-04-16 11:44 by scoder, last changed 2016-08-05 22:55 by berker.peksag. This issue is now closed.

Messages (6)
msg158412 - (view) Author: Stefan Behnel (scoder) * (Python committer) Date: 2012-04-16 11:44
The imp.load_dynamic() function is used by third party code (e.g. Cython's pyximport) but is not currently documented.

http://docs.python.org/dev/library/imp.html

The latest changes to the import mechanism suggest that it should better be documented to give a hint that users can rely on it.
msg158439 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-04-16 13:17
This is essentially a duplicate of issue 14551, but perhaps with a bit more weight behind it.
msg158440 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-04-16 13:21
Ok, let's redocument them, then :)
msg158457 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-04-16 14:22
Yeah, they really need to be documented in order for us to document them as deprecated if we decide we really want to remove them later.  "Obsolete" is not, I think, the same as "deprecated".
msg158471 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2012-04-16 15:41
I'm fine w/ documenting load_dynamic() and leaving it as-is since importlib uses the function itself (plus the frozen/builtin functions, although the frozen stuff might be simplified since they can probably just return the bytes for the frozen module instead of doing as much work in C code). But load_package(), load_source(), and load_module() need to go.
msg272069 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-08-05 22:55
The imp module has been deprecated long time ago and the importlib module itself doesn't it anymore. However, Cython still use it: https://github.com/cython/cython/blob/master/pyximport/pyximport.py#L217

I'm inclined to close this as 'out of date' but feel free to reopen it :)
History
Date User Action Args
2016-08-05 22:55:47berker.peksagsetstatus: open -> closed

nosy: + berker.peksag
messages: + msg272069

resolution: out of date
stage: resolved
2012-04-16 16:20:03eric.snowsetnosy: + eric.snow
2012-04-16 15:41:34brett.cannonsetmessages: + msg158471
2012-04-16 14:22:55r.david.murraysetmessages: + msg158457
2012-04-16 13:21:55pitrousetmessages: + msg158440
2012-04-16 13:17:42r.david.murraysetnosy: + r.david.murray, brett.cannon, pitrou

messages: + msg158439
versions: - Python 2.6, Python 3.1, Python 2.7
2012-04-16 11:44:43scodercreate