classification
Title: Add gzip support to xmlrpc.server
Type: enhancement Stage: needs patch
Components: Library (Lib) Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: eric.araujo, rhettinger, rosslagerwall
Priority: normal Keywords:

Created on 2012-04-14 20:48 by rhettinger, last changed 2012-05-16 20:11 by rosslagerwall. This issue is now closed.

Messages (2)
msg158282 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2012-04-14 20:48
The xmlrpclib client already supports gzipped data and say so in the HTTP header: "Accept-Encoding: gzip".

Our XMLRPC Server ignores this header and always sends uncompressed data.
msg160758 - (view) Author: Ross Lagerwall (rosslagerwall) (Python committer) Date: 2012-05-15 20:06
The server encodes the response if the length of the response exceeds self.encode_threshold, 1400 (presumably there's no point in compression if the data fits in the MTU anyway).
History
Date User Action Args
2012-05-16 20:11:20rosslagerwallsetstatus: open -> closed
resolution: not a bug
2012-05-15 20:06:18rosslagerwallsetnosy: + rosslagerwall
messages: + msg160758
2012-04-21 01:07:17eric.araujosetnosy: + eric.araujo

stage: needs patch
components: + Library (Lib)
title: Add gzip support the XMLRPC Server -> Add gzip support to xmlrpc.server
2012-04-14 20:48:16rhettingercreate