classification
Title: test_parsedate_acceptable_to_time_functions+DST == :-(
Type: behavior Stage: resolved
Components: Tests Versions:
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: barry Nosy List: anthonybaxter, barry, barry, r.david.murray
Priority: normal Keywords:

Created on 2006-03-20 07:47 by anthonybaxter, last changed 2010-01-11 20:11 by r.david.murray. This issue is now closed.

Messages (2)
msg60890 - (view) Author: Anthony Baxter (anthonybaxter) (Python triager) Date: 2006-03-20 07:47
TZ=UTC ./python ./Lib/test/test_email.py works fine.
But "TZ=Australia/Melbourne ./python
./Lib/test/test_email.py" breaks - the date used in
this test (5 Feb 2003) is during daylight savings time
here. It's unclear to me what the test is trying to do,
so assigning to Barry to look at.

FAILED (failures=1)
Traceback (most recent call last):
  File "./Lib/test/test_email.py", line 13, in <module>
    test_main()
  File "./Lib/test/test_email.py", line 10, in test_main
    run_suite(suite())
  File
"/home/anthony/src/py/pytrunk/python/Lib/test/test_support.py",
line 285, in run_suite
    raise TestFailed(err)
test.test_support.TestFailed: Traceback (most recent
call last):
  File
"/home/anthony/src/py/pytrunk/python/Lib/email/test/test_email.py",
line 2127, in test_parsedate_acceptable_to_time_functions
    eq(time.localtime(t)[:6], timetup[:6])
AssertionError: (2003, 2, 5, 14, 47, 26) != (2003, 2,
5, 13, 47, 26)
msg97599 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-01-11 20:11
I can't reproduce this.  If you can, please reopen.
History
Date User Action Args
2010-01-11 20:11:05r.david.murraysetstatus: open -> closed

components: + Tests, - None
type: behavior
nosy: + r.david.murray
messages: + msg97599
resolution: works for me
stage: resolved
2008-01-20 19:55:18georg.brandlsetassignee: bwarsaw.historic -> barry
nosy: + barry
2006-03-20 07:47:31anthonybaxtercreate