classification
Title: No link to issue tracker on Python home page
Type: Stage: resolved
Components: Versions:
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: Nosy List: eric.araujo, ezio.melotti, loewis, r.david.murray, steven.daprano, terry.reedy, valhallasw, weirdink13
Priority: normal Keywords:

Created on 2012-03-18 11:14 by steven.daprano, last changed 2012-03-26 02:09 by r.david.murray. This issue is now closed.

Messages (17)
msg156241 - (view) Author: Steven D'Aprano (steven.daprano) * (Python committer) Date: 2012-03-18 11:14
There is no link to the tracker http://bugs.python.org/ on the Python website http://www.python.org/ (or if there is, it's so well hidden I can't see it).

I seem to remember that there used to be; whether or not there was, there should be.

Curiously, the issue tracker itself includes a link to the issue tracker, in the side-bar.


Tested with Firefox 3.6, Konqueror, and wget + grep.
msg156245 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-03-18 11:23
I disagree that there should be such a link. www.python.org is the home page of the Python programming language, not of CPython. To find the tracker, go to "Core development", and find it in the "Resources" section.
msg156246 - (view) Author: Merlijn van Deen (valhallasw) * Date: 2012-03-18 11:31
Maybe, but python.org also is the host of CPython itself (and this issue tracker is also for issues on the programming language).

I think the "Core development" page makes sense, but having it in a sidebar instead of somewhere at the bottom of the page would be helpful, or an introduction that notes there are useful links at the bottom.  Maybe just move the "quick links" section to above the "quick start" section?

To be more specific- the devguide made me think 'oh, so this is the page on how I compile CPython, but I'm looking for the issue tracker. *clicks "back"*'
msg156283 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2012-03-18 22:41
The devguide index page links to the bug tracker on its ninth line.  Isn’t that enough?  If not, I’m +0 on adding a link.
msg156285 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-03-18 22:54
Interesting.  I would have said that an open source project ought to have a link for reporting bugs on the front page, but I just checked perl.org and apache.org, and they both put the bug tracker links on the 'get involved' page.

The devguide is *not* equivalent to those 'get involved' pages, and users are not likely to find the bug tracker link on it.  IMO we really should create a 'get involved' page, and link both the devguide and the bug tracker from it.
msg156287 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-03-18 23:07
I wish the devguide wouldn't have replaced the original "core development"  pages:

http://web.archive.org/web/20090305022527/http://www.python.org/dev/
msg156296 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-03-19 00:30
That is indeed better than the current devguide for introducing people to the community.  I think the current devguide is better at explaining the development process in detail, but that's not what is needed for a 'getting involved' page.
msg156299 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-03-19 00:50
I think the core issue here is that bug reporters often don't want to "get involved", and don't consider themselves contributors. Instead, they post to the bug tracker in order to get help.

In some cases, this is misguided (i.e. when Python behaves correctly, and they just fail to understand how it works). In other cases, they may report a genuine bug, but have no intention to work on this beyond installing a bug fix release, which they hope will be released quickly.

The question now really is how much we want to help people that want to "get support", rather than "getting involved". I think that a tracker link on www.python.org would primarily serve this kind of people, and I think it is giving them too much. If people want to get support for Python, they should hire somebody (and there are versions of Python with commercial support).

I think that we *somewhat* need to support people who don't want to get involved. Either the devguide needs to accommodate them better (e.g. with a introductory section: "Several ways to contribute"), or a separate page in front of the devguide is needed.
msg156305 - (view) Author: Steven D'Aprano (steven.daprano) * (Python committer) Date: 2012-03-19 01:43
Martin v. Löwis wrote:
> Martin v. Löwis <martin@v.loewis.de> added the comment:
> 
> I think the core issue here is that bug reporters often don't want to "get
> involved", and don't consider themselves contributors. Instead, they post
> to the bug tracker in order to get help.

Or they just want to make a bug report. Technically, this is "getting 
involved", but they don't think of it that way. I know I don't. Getting 
involved is submitting a patch. They want to do the right thing in reporting a 
bug, and then work around it until it is fixed.

Starting from the Python web site, it is not obvious how to find the issue 
tracker to report a bug. I had to resort to googling for "Python bug tracker" 
to find it.

I never would have thought that clicking "Core Development" was the way to get 
to a link to the issue tracker. I don't want to do core development, I want to 
report a bug.

And even on the core development page, there's nothing in the side-bar about 
the issue tracker. I have to actually *read the page content* to discover 
links to the tracker.

[...]
> The question now really is how much we want to help people that want to
> "get support", rather than "getting involved". I think that a tracker link
> on www.python.org would primarily serve this kind of people, and I think it

I think you are mistaken. I don't think that people looking for support raise 
bug requests. That's too much like work. They go to StackOverflow or one of 
the many Python mailing lists and say "Please fix my code".

Imagine you've written to comp.lang.python (python-list@python.org) and asked 
for help: "is this a bug?". 99 times out of 100, it's a bug in your code, but 
this time it turns out to be an actual bug. Somebody says, "yes, that's a bug, 
please report it on the issue tracker".

Where the hell is the issue tracker? How do you find it from the Python home 
page? You shouldn't have to resort to Google to find the tracker.

The home page has an explicit "Alternative download page for China". (Why 
China?) I'm sure that's important, but is it more important than the issue 
tracker, that it gets prime billing in the side-bar and the tracker doesn't?
msg156308 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-03-19 02:51
> I think you are mistaken. I don't think that people looking for support raise 
> bug requests.

There is *plenty* of evidence to the contrary, please trust me on that.

> The home page has an explicit "Alternative download page for China". (Why 
> China?)

Please also trust that there is a very good reason for that link which
I'm not going to reveal in public (else there is a risk that it becomes
pointless).

I remain -1 on adding a link to the tracker to www.python.org. As long
as we cannot really cope with the flood of bug reports that we get,
there is little point in making the tracker more prominent. Plus, using
Google is an established, useful practice, and it comes as the first
hit when searching for "Python bug tracker". "Python issue tracker"
brings it only as the second link, with the 2.7.2 documentation on
"Reporting bugs" being the first link.
msg156319 - (view) Author: Steven D'Aprano (steven.daprano) * (Python committer) Date: 2012-03-19 06:36
On Mon, Mar 19, 2012 at 02:51:53AM +0000, Martin v. Löwis wrote:
> 
> Martin v. Löwis <martin@v.loewis.de> added the comment:

> I remain -1 on adding a link to the tracker to www.python.org. As long
> as we cannot really cope with the flood of bug reports that we get,
> there is little point in making the tracker more prominent.

In other words, the fact that there is no link to the tracker on the 
main page is a feature, not a bug.

I can't say I'm happy about it, but I accept your reasoning.
msg156328 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-03-19 11:23
> Starting from the Python web site, it is not obvious how to find the issue 
> tracker to report a bug. (I had to resort to)

For this very reason, what I always do is

>  googling for "Python bug tracker" to find it.

Which doesn't mean that I agree that a link should be added to the homepage, but just that if I'm looking for a bug tracker, I search for "[projectname] bug tracker" rather than searching for "[projectname]" and then try to find a link to the bug tracker on their homepage.
I would probably do the same even if I knew there is a link to the bug tracker on the homepage. (For the Python bug tracker I have a dedicated button on my browser though :)
msg156600 - (view) Author: Daniel Swanson (weirdink13) Date: 2012-03-22 18:23
I agree that the link to the bug tracker should be more obvious (yesterday it took me almost an hour to find it)
msg156669 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-03-23 16:47
Could you tell us something more (e.g. where you were expecting to find it, where have you looked, how/where have you found it eventually, what search queries you have used)?
msg156696 - (view) Author: Daniel Swanson (weirdink13) Date: 2012-03-24 15:51
i don't remember
msg156724 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2012-03-25 00:15
This issue seems 'off-topic' in that core developers do not control the main site and cannot patch it. My understanding is that that is why the dev guide was separated from the main site (so we could patch it). On the other hand, we can suggest changes like anyone else.

We (core devs) do not want this tracker used for everyday support requests. They are a minor but not non-existent problem. They will get quicker and ofter better responses on other, more appropriate forums.

In the future, when I suggest 'report that on the tracker' on python-list, I will try to remember to include 'at bugs.python.org'. 

I do think there should be a Reporting Bugs page (or section) and link somewhere on the site, but not on the front page. Apparently there already is something like that. A 'Getting Involved' page is a traditional place.

That gateway would ideally be the first hit for a 'report bug' or 'bug tracker' site search. However, even now, the first hit summary for either search gives the necessary information in spite of the strange doc link. 

"Reporting Bugs in Python — Python v2.6.5c2 documentation
www.python.org/doc//current/bugs.html
Mar 13, 2010 – Bug reports should be submitted via the Python Bug Tracker (http://bugs.python.org/). The bug tracker offers a Web form which allows pertinent ..."

Perhaps neither Steven or Daniel noticed the 'quiet' search box. I would like to see a label that specifies what is searched. See Advanced Search for possibilities. It could also be moved to the center to better attract attention.

Stephen, you are free to send a suggestion to webmaster@python.org. Since you asked for input here, I would hope you would incorporate it ;-). You can also close this when you think discussion has run out.
msg156795 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-03-26 02:09
OK, so whatever else is true, it seems like there isn't anything for the python core dev team to do here.  Any action would take place at the www.python.org level, and this bug tracker isn't where such changes are tracked, so I'm closing the issue.  Especially since the consensus seems to be that the bug tracker should *not* be linked from the main page...
History
Date User Action Args
2012-03-26 02:09:03r.david.murraysetstatus: open -> closed
resolution: rejected
messages: + msg156795

stage: resolved
2012-03-25 00:15:24terry.reedysetnosy: + terry.reedy
messages: + msg156724
2012-03-24 15:51:22weirdink13setmessages: + msg156696
2012-03-23 16:47:23ezio.melottisetmessages: + msg156669
2012-03-22 18:23:34weirdink13setnosy: + weirdink13
messages: + msg156600
2012-03-19 11:23:31ezio.melottisetnosy: + ezio.melotti
messages: + msg156328
2012-03-19 06:36:20steven.dapranosetmessages: + msg156319
2012-03-19 02:51:53loewissetmessages: + msg156308
2012-03-19 01:43:53steven.dapranosetmessages: + msg156305
2012-03-19 00:50:45loewissetmessages: + msg156299
2012-03-19 00:30:52r.david.murraysetmessages: + msg156296
2012-03-18 23:07:04loewissetmessages: + msg156287
2012-03-18 22:54:10r.david.murraysetnosy: + r.david.murray
messages: + msg156285
2012-03-18 22:41:59eric.araujosetnosy: + eric.araujo
messages: + msg156283
2012-03-18 11:31:50valhallaswsetnosy: + valhallasw
messages: + msg156246
2012-03-18 11:23:52loewissetnosy: + loewis
messages: + msg156245
2012-03-18 11:14:27steven.dapranocreate