classification
Title: Proper gettext support in locale module
Type: enhancement Stage: resolved
Components: Build Versions: Python 2.7, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: a.badger, benjamin.peterson, loewis, melflynn
Priority: normal Keywords: patch

Created on 2012-03-17 20:49 by melflynn, last changed 2019-05-12 20:47 by benjamin.peterson. This issue is now closed.

Files
File name Uploaded Description Edit
python26-configure.in.patch melflynn, 2012-03-17 20:49 Patch against 2.6 branch configure
python27-configure.in.patch melflynn, 2012-03-17 20:50 Patch for 2.7 configure.in
Pull Requests
URL Status Linked Edit
PR 13265 merged a.badger, 2019-05-12 17:49
Messages (5)
msg156203 - (view) Author: Mel Flynn (melflynn) Date: 2012-03-17 20:49
Gettext support in Python is configured by two tests:
- textdomain in libc or libintl
- bind_textdomain_codeset in libc only

The latter causes incomplete gettext support in the locale module. Since the implementation uses two different defines, the provided patch provides them and also ensures they exist.

The issue is not present in 3.x branches, as only a single test is done for full gettext support in locale.
msg156204 - (view) Author: Mel Flynn (melflynn) Date: 2012-03-17 20:50
Additional patch for 2.7 branch.
msg341943 - (view) Author: Toshio Kuratomi (a.badger) * Date: 2019-05-08 21:02
As this problem does not affect Python3 I think it's up to the 2.7 release manager to decide if it should be merged.  benjamin, what do you think?  If you want it, I'll open a PR on github for it.
msg342044 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2019-05-10 02:30
seems okay
msg342265 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2019-05-12 20:47
New changeset 24ff9a44ac5f0653df4c1d92c2a99fab286fcc15 by Benjamin Peterson (Toshio Kuratomi) in branch '2.7':
[2.7] closes bpo-14353: Fix detection of bind_textdomain_codeset in libintl. (GH-13265)
https://github.com/python/cpython/commit/24ff9a44ac5f0653df4c1d92c2a99fab286fcc15
History
Date User Action Args
2019-05-12 20:47:29benjamin.petersonsetstatus: open -> closed
resolution: fixed
messages: + msg342265

stage: patch review -> resolved
2019-05-12 17:49:30a.badgersetstage: patch review
pull_requests: + pull_request13173
2019-05-10 02:30:50benjamin.petersonsetmessages: + msg342044
2019-05-08 21:02:40a.badgersetnosy: + benjamin.peterson, a.badger
messages: + msg341943
2012-03-17 20:54:39r.david.murraysetnosy: + loewis
2012-03-17 20:50:46melflynnsetfiles: + python27-configure.in.patch

messages: + msg156204
2012-03-17 20:49:56melflynncreate