classification
Title: test_subprocess fails on SuSE 10
Type: Stage:
Components: Tests Versions: Python 2.5
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, dvadasz
Priority: normal Keywords:

Created on 2007-11-09 13:30 by dvadasz, last changed 2007-11-25 20:21 by christian.heimes. This issue is now closed.

Files
File name Uploaded Description Edit
unnamed dvadasz, 2007-11-12 11:28
Messages (4)
msg57301 - (view) Author: Denes Vadasz (dvadasz) Date: 2007-11-09 13:30
I compiled Python 2.5.1 on SuSE 10 and ran "make test", which reported 
test_subprocess.py to fail on lines 537 and 579 with "permission 
denied".

After a short investigation it looks the problem is that in SuSE 10 the 
shell (bash) rejects to execute scripts residing in the /tmp directory 
even if the file permissions would allow that.

An easy way of fixing this could be to place the shell script 
statically in the same directory as test_subprocess.py instead of 
creating it on-the-fly in /tmp.
msg57360 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-10 22:05
Please try this:

$ mkdir -p ~/tmp
$ TMP=~/tmp make test
msg57395 - (view) Author: Denes Vadasz (dvadasz) Date: 2007-11-12 11:28
When I say:

$ mkdir -p ~/tmp
$ TMP=3D~/tmp python Lib/tests/test=5Fsubprocess.py

the test is passed.

However with

$ TMP=3D~/tmp make test

the test still fails and the ~/tmp directory is removed during the test 
run.

Regards
Denes Vadasz

Christian Heimes <report@bugs.python.org> 
To
dvadasz@amadeus.net
cc

bcc

Subject
[issue1412] test_subprocess fails on SuSE 10

Christian Heimes <report@bugs.python.org>
Please respond to : Tracker <report@bugs.python.org>
10/11/2007 23:05

Christian Heimes added the comment:

Please try this:

$ mkdir -p ~/tmp
$ TMP=~/tmp make test

----------
nosy: +tiran

__________________________________
Tracker <report@bugs.python.org>
<http://bugs.python.org/issue1412>
__________________________________

IMPORTANT  -  CONFIDENTIALITY  NOTICE  - This e-mail is intended only for 
the use of the individual or entity shown above as addressees . It may 
contain information which is privileged, confidential or otherwise 
protected from disclosure under applicable laws .  If the reader of this 
transmission is not the intended recipient, you are hereby notified that 
any dissemination, printing, distribution, copying, disclosure or the 
taking of any action in reliance on the contents of this information is 
strictly prohibited.  If you have received this transmission in error, 
please immediately notify us by reply e-mail or using the address below 
and delete the message and any attachments from your system . 

Amadeus Data Processing GmbH 
Geschäftsführer: Eberhard Haag 
Sitz der Gesellschaft: Erding 
HR München 48 199 
Berghamer Strasse 6 
85435 Erding 
Germany
msg57833 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-25 20:21
I've fixed a bug in py3k and 2.6 where a test in test_shutil has removed
an empty TMP directory. I regard the issue as a minor inconvenience. We
can't work around every edge case.
History
Date User Action Args
2007-11-25 20:21:10christian.heimessetstatus: open -> closed
resolution: works for me
messages: + msg57833
2007-11-12 11:28:16dvadaszsetfiles: + unnamed
messages: + msg57395
2007-11-10 22:05:24christian.heimessetnosy: + christian.heimes
messages: + msg57360
2007-11-09 13:30:50dvadaszcreate