classification
Title: warnings module bug: BytesWarning: str() on a bytes instance
Type: behavior Stage:
Components: Library (Lib) Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: christian.heimes Nosy List: christian.heimes
Priority: normal Keywords: patch

Created on 2007-11-08 14:02 by christian.heimes, last changed 2010-04-27 20:31 by loewis. This issue is now closed.

Messages (2)
msg57245 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-08 14:02
$ ./python -bb Lib/compileall.py
Listing /home/heimes/dev/python/py3k/Lib ...
Compiling /home/heimes/dev/python/py3k/Lib/pydoc.py ...
Traceback (most recent call last):
  File "Lib/compileall.py", line 162, in <module>
    exit_status = int(not main())
  File "Lib/compileall.py", line 155, in main
    success = compile_path()
  File "Lib/compileall.py", line 110, in compile_path
    force, quiet=quiet)
  File "Lib/compileall.py", line 65, in compile_dir
    ok = py_compile.compile(fullname, None, dfile, True)
  File "/home/heimes/dev/python/py3k/Lib/py_compile.py", line 131, in
compile
    encoding = read_encoding(file, "utf-8")
  File "/home/heimes/dev/python/py3k/Lib/py_compile.py", line 91, in
read_encoding
    return str(m.group(1))
  File "/home/heimes/dev/python/py3k/Lib/warnings.py", line 62, in warn
    globals)
  File "/home/heimes/dev/python/py3k/Lib/warnings.py", line 102, in
warn_explicit
    raise message
BytesWarning: str() on a bytes instance
msg57258 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-08 16:36
No bug at all ;)
History
Date User Action Args
2010-04-27 20:31:22loewissetpriority: normal
2007-11-08 16:36:07christian.heimessetstatus: open -> closed
priority: high -> (no value)
resolution: not a bug
messages: + msg57258
2007-11-08 14:02:42christian.heimescreate