classification
Title: os.path.exists inconsistent between 32 bit and 64 bit
Type: behavior Stage: resolved
Components: Windows Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: tim.golden, zxw
Priority: normal Keywords:

Created on 2012-02-03 15:44 by zxw, last changed 2012-02-06 12:46 by zxw. This issue is now closed.

Messages (4)
msg152524 - (view) Author: zxw (zxw) Date: 2012-02-03 15:44
When I run the following line while the 32 bit version of python is installed it returns false, however with the 64 bit version it correctly returns true.
os.path.exists('C:\\Windows\\System32\\msg.exe')

I'm using Python 2.7.2 with Windows 7 Professional 64bit.
msg152527 - (view) Author: Tim Golden (tim.golden) * (Python committer) Date: 2012-02-03 15:53
This is the Windows x64 file system redirector at work. I can't get 
through to msdn at the moment to get a link, but Google for those
terms.
msg152542 - (view) Author: zxw (zxw) Date: 2012-02-03 17:03
Ok, thanks, that fixed it. I'll probably post some example code for anyone else who stumbles across this with the same problem, don't have the time right now however.
msg152733 - (view) Author: zxw (zxw) Date: 2012-02-06 12:46
I've posted the code to http://code.activestate.com/recipes/578035-disable-file-system-redirector/
History
Date User Action Args
2012-02-06 12:46:57zxwsetmessages: + msg152733
2012-02-03 17:09:01brian.curtinsetresolution: not a bug
stage: resolved
2012-02-03 17:03:09zxwsetstatus: open -> closed

messages: + msg152542
2012-02-03 15:53:50tim.goldensetnosy: + tim.golden
messages: + msg152527
2012-02-03 15:44:56zxwcreate