classification
Title: Python 2.7.2 and 3.2.2 execl crash
Type: crash Stage:
Components: Windows Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Interpreter crashes on invalid arg to spawnl on Windows
View: 8036
Assigned To: Nosy List: shinnai, tim.golden
Priority: normal Keywords:

Created on 2012-02-01 13:03 by shinnai, last changed 2012-02-01 14:04 by pitrou. This issue is now closed.

Messages (2)
msg152428 - (view) Author: Carlo Di Dato (shinnai) Date: 2012-02-01 13:03
These lines make Python 2.7.2 and 3.2.2 crash

import os
os.execl("cmd.exe", "")

Regards
msg152429 - (view) Author: Tim Golden (tim.golden) * (Python committer) Date: 2012-02-01 13:16
This is a duplicate of http://bugs.python.org/issue8036

(which I still haven't got around to applying...)
History
Date User Action Args
2012-02-01 14:04:27pitrousetstatus: open -> closed
resolution: duplicate
superseder: Interpreter crashes on invalid arg to spawnl on Windows
2012-02-01 13:16:01tim.goldensetnosy: + tim.golden
messages: + msg152429
2012-02-01 13:04:27shinnaisetversions: + Python 3.2, - Python 3.1
2012-02-01 13:03:46shinnaicreate