classification
Title: Add hyphen doc fix
Type: enhancement Stage:
Components: Documentation Versions: Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Retro, docs@python, georg.brandl, mark.dickinson, pitrou, rhettinger, sandro.tosi, skrah
Priority: normal Keywords: patch

Created on 2012-01-25 23:58 by Retro, last changed 2012-02-02 05:40 by rhettinger. This issue is now closed.

Files
File name Uploaded Description Edit
smallfix.diff Retro, 2012-01-25 23:58 Adds a hyphen :) review
Messages (16)
msg151985 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-25 23:58
When you have time, incorporate this patch. Thanks.
msg152110 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2012-01-27 18:43
There are a lot more occurrences of 'floating point' in our doc: are you going to fix them too?
msg152262 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-29 21:34
If "floating point" in a sentence is in a role of an adjective, then it must be written as "floating-point" (with a hyphen), otherwise not.

Example: "The number 3.5 is a floating-point number."

Please consult some English orthography book and start writing correct English.
msg152287 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2012-01-29 23:32
Wow.. do you really expect any positive outcome from you reply style?

I'll pretend I didn't read your reply and let me rephrase my question like this: there are several occurrences of 'floating point' in python doc, are you going to fix all the ones that are wrong?
msg152318 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-30 14:08
I know that there are a lot of non-hyphenated occurences of "floating point" in Python docs, so I just want to raise awareness about those occurences. Can you fix all occurences of "floating point" (when in a role of an adjective) to "floating-point" throughout Python docs?

As a matter of fact, everything that is an adjective is hyphenated if there are 2 words that form the adjective.

Example: "This is built in." versus "This is a built-in method."
msg152319 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2012-01-30 14:15
On Mon, Jan 30, 2012 at 15:08, Boštjan Mejak <report@bugs.python.org> wrote:
> Can you fix all occurences of "floating point" (when in a role of an adjective) to "floating-point" throughout Python docs?

What I was asking is if *you* (since you care about the topic) would
provide a patch fixing all that needs fixing. At that point there will
be people interesting reviewing your patch, instead of people been
told what to do.

Regards,
Sandro
msg152321 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-01-30 14:24
Congratulations: You (again) have found a fundamental error in TAOCP.
Example (Third Edition, page 233):

"The following definitions seem to be appropriate for base b, excess q,
floating point numbers ..."
msg152324 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-30 15:14
For the time being I don't find any other "floating point" occurences in Python docs. I found one and made a patch for it. Please apply the patch.  Thanks.
msg152347 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2012-01-30 21:09
Wow, does that mean he can cash in a Knuth check?
msg152382 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-31 13:03
What's the purpose of this tracker if the author of an issue report has to beg for something to be fixed, despite the fact that (s)he even made a patch ?????
msg152407 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-01-31 21:28
Georg Brandl <report@bugs.python.org> wrote:
> Wow, does that mean he can cash in a Knuth check?

Two already: One for the insight that "i-th" is the only true spelling,
and now this one.
msg152431 - (view) Author: Boštjan Mejak (Retro) Date: 2012-02-01 14:42

Message has been classified as spam.

msg152432 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2012-02-01 14:45
On Wed, Feb 1, 2012 at 15:42, Boštjan Mejak <report@bugs.python.org> wrote:
> Seriously, how old are you two clowns?

I think it's enough: FTR I'm +1 on removing Retro tracker account,
effective immediately (if any admin is around).
msg152434 - (view) Author: Boštjan Mejak (Retro) Date: 2012-02-01 14:59

Message has been classified as spam.

msg152437 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-02-01 15:21
Retro, your contributions are not welcome anymore.
msg152454 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2012-02-02 05:40
Boštjan, please stop wasting everyone's time.
History
Date User Action Args
2012-02-02 05:40:17rhettingersetnosy: + rhettinger
messages: + msg152454
2012-02-01 19:37:28georg.brandlsetstatus: open -> closed
resolution: not a bug
2012-02-01 15:21:58pitrousetnosy: + pitrou
messages: + msg152437
2012-02-01 14:59:57Retrosetmessages: + msg152434
2012-02-01 14:45:14sandro.tosisetmessages: + msg152432
2012-02-01 14:42:16Retrosetmessages: + msg152431
2012-01-31 21:28:44skrahsetmessages: + msg152407
2012-01-31 13:03:31Retrosetmessages: + msg152382
2012-01-30 21:09:17georg.brandlsetnosy: + georg.brandl
messages: + msg152347
2012-01-30 15:14:25Retrosetmessages: + msg152324
2012-01-30 14:24:09skrahsetnosy: + skrah
messages: + msg152321
2012-01-30 14:15:07sandro.tosisetmessages: + msg152319
2012-01-30 14:08:08Retrosetmessages: + msg152318
2012-01-29 23:32:23sandro.tosisetmessages: + msg152287
2012-01-29 21:34:37Retrosetmessages: + msg152262
2012-01-27 19:34:16mark.dickinsonsetnosy: + mark.dickinson
2012-01-27 18:43:28sandro.tosisetnosy: + sandro.tosi
messages: + msg152110
2012-01-25 23:58:10Retrocreate