classification
Title: Two typos in the docs
Type: enhancement Stage:
Components: Documentation Versions: Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Retro, docs@python, dontknow, ezio.melotti, georg.brandl, python-dev, terry.reedy
Priority: normal Keywords: patch

Created on 2012-01-18 16:23 by Retro, last changed 2012-01-23 21:12 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
hyphen_removed_key_function.diff dontknow, 2012-01-18 18:28 removed hyphen review
i_th_hyphen.diff dontknow, 2012-01-18 18:30 changed apostrophe to hyphen review
issue13816.diff dontknow, 2012-01-23 17:23 review
Messages (23)
msg151547 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-18 16:23
There's a typo in the docs for cmp_to_key() function. Fix the first sentence "Transform an old-style comparison function to a key-function." to "Transform an old-style comparison function to a key function." (delete the hyphen between words "key" and "function")

http://docs.python.org/library/functools.html#functools.cmp_to_key

------------------------------------------------------------------

There's another typo in the docs lurking in http://docs.python.org/library/stdtypes.html#sequence-types-str-unicode-list-tuple-bytearray-buffer-xrange

Look for the table with the columns "Operation", "Result", "Notes" (scroll down and you'll find it), and fix the text of the fifth cell under the "Result" column like this:
"i'th item of s, origin 0"  -->  "i-th item of s, origin 0".

Change that apostrophe into a hyphen, so "i'th" to "i-th". Thanks, Ezio.
msg151551 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-01-18 16:46
Just as a note: It is not acceptable to be rude on the tracker or
to remove people from the nosy list as you did in #13695.
msg151552 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2012-01-18 17:14
And not really working, as I get updates for all assignments to docs@python anyway.
msg151553 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-18 17:17
I am deeply and truly sorry. Can we now fix this?
msg151558 - (view) Author: John (dontknow) Date: 2012-01-18 18:28
Removed the hyphen in function keys.
Didn't really see a problem with using an apostrophe in 'ith' instead of a hyphen because I have seen it done both ways but changed it anyways.
This is my first contribution so i needed the practice.  Hope I did everything correctly.
msg151721 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2012-01-21 04:50
The Chicago Manual of Style. which is perhaps the mostly widely used general style manual in the US, uses 'th' as a suffix without ' or -.
ie, 28th, etc except for 22d ('preferred' to 22nd) and 23d ('preferred' to 23rd).

https://en.wiktionary.org/wiki/nth
gives nth, which I use, with *n*th (italic n) as alternate form (when italic is available) and n'th and n-th as 'sometimes used'. I think both of the last two are ugly and that we should use either nth or, since we can, *n*th.  I see that we already have *i*.
msg151743 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-01-21 20:35
> ... with *n*th (italic n) as alternate form

Knuth uses that in TAOCP, too. I think with or without italics it's
the most frequently used form overall.

Also the Lisp function is called nth and not n-th, even though in Lisp
it is possible to use hyphens in function names.
msg151766 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-22 10:11
Terry, I agree with you on having *i*th instead of *i*-th. The fact that "i" is written in italics eliminates the need of a hyphen.

Justin, can I ask you to make a new patch which fixes "key-function" to "key function" and *i*'th to *i*th

This is the last decision. Also, if anyone of you can, please then just incorporate that final patch that Justin will make. Thanks.
msg151767 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-01-22 10:22
> This is the last decision. Also, if anyone of you can, please then just > incorporate that final patch that Justin will make. Thanks.

Stop acting like a manager. A while ago a person had his account
disabled for constantly bumping up issues and telling other people
what to do.
msg151768 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-22 10:39
Yeah, I guess I was kind of rude. Sorry about that. I think my proposal is acceptable. What do you think?
msg151775 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2012-01-22 14:25
Justin, if you do a new patch, put both changes in one .diff.
msg151786 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-22 19:49
I fixed Justin's patch. Anyone cares to incorporate it?
msg151787 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2012-01-22 20:24
Sorry, but the patch introduces two markup errors:

- *i*th is invalid reST, it needs to be *i*\ th
- you broke the table markup (the vertical lines must be aligned)
msg151810 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-23 11:38
Georg, thanks for the tip. Is there any difference in reST between *i*\ th and *i*\th ?
msg151811 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-01-23 11:48
You can check on the devguide the section about building the doc and see it yourself on the generated HTML.  While building you will also see all the warnings caused by invalid markup.
msg151816 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-23 14:02
I hope the patch is now good. What do you think?
msg151817 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-23 14:26
Ah, darn it! My last patch is a total garbage. But then an interesting thing happened: I wanted to delete my last patch set, but I got a

"ProgrammingError at /review/13816/patchset/4039/delete
schema "datetime" does not exist"

and got all the Django nitty-gritty info about your server. This is not good because someone can misuse that information. Please fix this. You have "DEBUG = True" set and so all the details of your server is leaked. Better change that to "DEBUG = False" and let the user get a standard 500 error page instead.

It says at the bottom: "You're seeing this error because you have DEBUG = True in your Django settings file. Change that to False, and Django will display a standard 500 page."
msg151820 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-23 14:46
I wasn't able to remove the patch via "Delete Patch Set" but I did it by clicking on the Unlink button. So the "Delete Patch Set" option has a bug.
msg151821 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-23 15:02
Georg, I object to your comment about *i*th needing to be *i*\ th

because currently in the source code we have it written as *i*'th which, by your logic, would need to be written as *i*\ 'th

which is not so and is compiled/displayed/whatever perfectly as is, so *i*th would be compiled/displayed/whatever, too.
msg151822 - (view) Author: Boštjan Mejak (Retro) Date: 2012-01-23 15:25
This stupid HG is so cryptic. SVN was so easy, now I can't even create a patch. Can you just fix those two typos as "key function" and "*i*th" please? Thank you.
msg151830 - (view) Author: John (dontknow) Date: 2012-01-23 17:23
Fixed.
msg151836 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2012-01-23 19:21
1. Please report issues with the tracker to the meta-tracker at http://psf.upfronthosting.co.za/roundup/meta/.

2. You may object all you want, *i*th is invalid reST and a very quick tryout with "rst2html" would have shown you that.

3. Lastly, it is usual to test patches before submitting. Had you tried to build your changed docs instead of complaining here, you might have been enlightened.

Justin: thanks for the patch.
msg151837 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-01-23 19:21
New changeset a72ca8b23cdf by Georg Brandl in branch '3.2':
#13816: fix two minor style issues. Thanks to Justin Wehnes for the patch.
http://hg.python.org/cpython/rev/a72ca8b23cdf

New changeset f4f9ab2fd51b by Georg Brandl in branch '2.7':
#13816: fix two minor style issues. Thanks to Justin Wehnes for the patch.
http://hg.python.org/cpython/rev/f4f9ab2fd51b
History
Date User Action Args
2012-01-23 21:12:48georg.brandlsetstatus: open -> closed
resolution: fixed
2012-01-23 19:21:54python-devsetnosy: + python-dev
messages: + msg151837
2012-01-23 19:21:48georg.brandlsetmessages: + msg151836
2012-01-23 17:23:02dontknowsetfiles: + issue13816.diff

messages: + msg151830
2012-01-23 15:27:56skrahsetnosy: - skrah
2012-01-23 15:25:16Retrosetmessages: + msg151822
2012-01-23 15:02:13Retrosetmessages: + msg151821
2012-01-23 14:46:51Retrosetmessages: + msg151820
2012-01-23 14:36:31Retrosetfiles: - fixed patch final.diff
2012-01-23 14:36:07Retrosetfiles: - done deal.diff
2012-01-23 14:26:52Retrosetmessages: + msg151817
2012-01-23 14:02:11Retrosetfiles: + done deal.diff

messages: + msg151816
2012-01-23 11:48:35ezio.melottisetmessages: + msg151811
2012-01-23 11:38:02Retrosetmessages: + msg151810
2012-01-22 20:24:49georg.brandlsetmessages: + msg151787
2012-01-22 19:49:39Retrosetfiles: + fixed patch final.diff

messages: + msg151786
2012-01-22 14:25:38terry.reedysetmessages: + msg151775
2012-01-22 10:39:20Retrosetmessages: + msg151768
2012-01-22 10:22:01skrahsetmessages: + msg151767
2012-01-22 10:11:42Retrosetmessages: + msg151766
2012-01-21 20:35:34skrahsetmessages: + msg151743
2012-01-21 04:50:13terry.reedysetnosy: + terry.reedy
messages: + msg151721
2012-01-18 18:30:00dontknowsetfiles: + i_th_hyphen.diff
2012-01-18 18:28:53dontknowsetfiles: + hyphen_removed_key_function.diff

nosy: + dontknow
messages: + msg151558

keywords: + patch
2012-01-18 17:17:37Retrosetmessages: + msg151553
2012-01-18 17:14:00georg.brandlsetnosy: + georg.brandl
messages: + msg151552
2012-01-18 16:46:57skrahsetnosy: + skrah
messages: + msg151551
2012-01-18 16:23:14Retrocreate