classification
Title: formatter_unicode.c still assumes ASCII
Type: behavior Stage: resolved
Components: Unicode Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Jim.Jewett, eric.smith, ezio.melotti
Priority: normal Keywords:

Created on 2012-01-12 15:15 by Jim.Jewett, last changed 2012-01-12 15:30 by eric.smith. This issue is now closed.

Messages (2)
msg151128 - (view) Author: Jim Jewett (Jim.Jewett) * (Python triager) Date: 2012-01-12 15:15
http://docs.python.org/library/string.html#format-specification-mini-language defines

    fill        ::=  <a character other than '}'>

and the text also excludes '{'.  It does not require that the fill character be ASCII.

However, function parse_internal_render_format_spec 
http://hg.python.org/cpython/file/c2153ce1b5dd/Python/formatter_unicode.c#l277 raises a ValueError if fill_char > 127.

I'm honestly not certain which of the three is correct, but they should be consistent, and if anything but '{' is excluded, it would be best to explain why.
msg151130 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2012-01-12 15:30
This is a duplicate of issue 13706.
History
Date User Action Args
2012-01-12 15:30:14eric.smithsetstatus: open -> closed

nosy: + eric.smith
messages: + msg151130

resolution: duplicate
stage: resolved
2012-01-12 15:15:10Jim.Jewettcreate