classification
Title: pootle.python.org is outdated.
Type: Stage:
Components: Documentation Versions:
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: docs@python Nosy List: benjamin.peterson, docs@python, eric.araujo, ezio.melotti, georg.brandl, inada.naoki, lehmannro, loewis, sandro.tosi
Priority: normal Keywords:

Created on 2011-12-26 12:50 by inada.naoki, last changed 2014-02-16 15:34 by benjamin.peterson. This issue is now closed.

Messages (8)
msg150261 - (view) Author: Inada Naoki (inada.naoki) * (Python committer) Date: 2011-12-26 12:50
I am one of Japanese translate of Python documents.
We have done translating Python 2.7 document and will start
translating Python 3.2 or 3.3.

I want to use sphinx-i18n and pootle to translate.
But http://pootle.python.org/ is very outdated.
Anyone can update the site?
If nobody maintain the site, could I create Python Document project at http://pootle.locamotion.org/ ?
msg150380 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-12-30 15:01
I'd rather have you maintain poodle.python.org instead of maintaining Python translations off-site.
msg150416 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-12-31 11:26
Agreed with Martin.  I would be nice to get a statement on the status of pootle.python.org (social aspects like updating and publishing the translations + organization of teams), but Georg seems busy.

(This would probably be more at home on a mailing list rather than in the CPython bug tracker.)
msg150417 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2011-12-31 11:43
I've never really had a hand in pootle.python.org; it was set up by Martin and Robert Lehmann, and Sandro Tosi also wanted to lend a hand...
msg150418 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2011-12-31 11:49
Yeah, I really would like to help with pootle, but it seems we don't have a current status of the thing + a roadmap to where we want to go.

From the top of my head, I think we need at least:

- the current setup of the machine/service
- updated packages for pootle + its deps (it should be a debian machine, so I can leverage my DD status to help here)
- plan the migration from the current pootle to the updated one
- start advertise pootle, which is much better than having a lot of people translating python doc on their own websites instead of a central (official) place
- maybe rename the service?
msg150420 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-12-31 14:31
naoki: what is your actual complaint about the installation being outdated? Are you referring to the message catalog (documentation version), or the software?

As for the message catalog, I don't think it should be updated too often (only once per Python release), otherwise, translators will have to fight a moving target (which they will have to, anyway, given that the documentation evolves).

Whatever updating procedure is performed: preserving the existing translations and the existing accounts is an absolute must.

I'm not sure what good renaming the service would do; this sounds like bike shedding.
msg150422 - (view) Author: Inada Naoki (inada.naoki) * (Python committer) Date: 2011-12-31 16:33
On Sat, Dec 31, 2011 at 11:31 PM, Martin v. Löwis
<report@bugs.python.org> wrote:
>
> Martin v. Löwis <martin@v.loewis.de> added the comment:
>
> naoki: what is your actual complaint about the installation being outdated? Are you referring to the message catalog (documentation version), or the software?

I need Python 3.2's message catalog. But updating pootle version is
also nice to me.

> As for the message catalog, I don't think it should be updated too often (only once per Python release), otherwise, translators will have to fight a moving target (which they will have to, anyway, given that the documentation evolves).
>

I agree with you about already released series (~3.2).
I think updating message catalog for beta versions may help releasing new
Python's translated document fast.

The way to manage multiple series is also needed when Python 3.3 is released.
msg211321 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2014-02-16 15:34
pootle.python.org has been disabled.
History
Date User Action Args
2014-02-16 15:34:07benjamin.petersonsetstatus: open -> closed

nosy: + benjamin.peterson
messages: + msg211321

resolution: wont fix
2012-01-02 17:34:38ezio.melottisetnosy: + ezio.melotti
2011-12-31 16:33:02inada.naokisetmessages: + msg150422
2011-12-31 14:31:40loewissetmessages: + msg150420
2011-12-31 11:49:36sandro.tosisetmessages: + msg150418
2011-12-31 11:43:16georg.brandlsetnosy: + lehmannro, sandro.tosi
messages: + msg150417
2011-12-31 11:26:37eric.araujosetmessages: + msg150416
2011-12-31 11:22:54eric.araujosetnosy: + eric.araujo

versions: - Python 2.7, Python 3.2, Python 3.3, Python 3.4
2011-12-30 15:01:29loewissetmessages: + msg150380
2011-12-27 19:08:59pitrousetnosy: + loewis, georg.brandl
2011-12-26 12:50:08inada.naokicreate