classification
Title: Clean Lib/_sysconfigdata.py and Modules/_testembed
Type: behavior Stage: resolved
Components: Build Versions: Python 3.2, Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: pitrou, python-dev, skrah
Priority: normal Keywords:

Created on 2011-12-07 15:53 by skrah, last changed 2011-12-09 17:32 by skrah. This issue is now closed.

Messages (6)
msg148969 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2011-12-07 15:53
I think that `make distclean` should remove Lib/_sysconfigdata.py and
Modules/_testembed. On second thought, `make clean` should probably
also remove those.
msg148970 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-12-07 15:56
Yes, "make clean" should remove them as well.
msg149057 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2011-12-08 22:34
New changeset 8ed2c4d4df62 by Stefan Krah in branch '3.2':
Issue #13547: clean Lib/_sysconfigdata.py and Modules/_testembed
http://hg.python.org/cpython/rev/8ed2c4d4df62

New changeset 053c95ad09cf by Stefan Krah in branch 'default':
Merge fix for issue #13547.
http://hg.python.org/cpython/rev/053c95ad09cf
msg149080 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2011-12-09 08:44
I guess this still needs to be fixed for Visual Studio.
msg149108 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-12-09 17:02
None of these two files is generated under Windows (_sysconfigdata.py by design and _testembed because nobody volunteered to do it).
msg149112 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2011-12-09 17:32
Excellent, closing then.
History
Date User Action Args
2011-12-09 17:32:06skrahsetstatus: open -> closed
resolution: fixed
messages: + msg149112

stage: needs patch -> resolved
2011-12-09 17:02:01pitrousetmessages: + msg149108
2011-12-09 08:44:24skrahsetmessages: + msg149080
2011-12-08 22:34:28python-devsetnosy: + python-dev
messages: + msg149057
2011-12-07 15:56:09pitrousetnosy: + pitrou

messages: + msg148970
versions: + Python 3.2
2011-12-07 15:53:29skrahcreate