classification
Title: A user may need ... when she has ...
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, flox, pitrou
Priority: low Keywords:

Created on 2011-11-24 07:26 by flox, last changed 2011-11-24 14:56 by flox. This issue is now closed.

Messages (3)
msg148231 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2011-11-24 07:25
http://docs.python.org/library/sys.html#sys.setrecursionlimit
http://docs.python.org/dev/library/sys.html#sys.setrecursionlimit

Doc for Python 2.7 says:
"A user may need to set the limit higher when she has ..."

Doc for Python 3.3 says:
"A user may need to set the limit higher when they have ..."


IMHO "she" and "they" are not right here.
Is it an initiative of the "Python diversity" group :-)
msg148243 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-11-24 11:31
"they" is right and "she" is actually right too.

See http://en.wikipedia.org/wiki/Singular_they
msg148259 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2011-11-24 14:56
This explanation is enough. Thanks.
History
Date User Action Args
2011-11-24 14:56:58floxsetstatus: pending -> closed
resolution: works for me -> not a bug
messages: + msg148259

stage: needs patch -> resolved
2011-11-24 11:31:03pitrousetstatus: open -> pending

nosy: + pitrou
messages: + msg148243

resolution: works for me
2011-11-24 07:26:00floxcreate