classification
Title: test_time fails: tzset() do not change timezone
Type: behavior Stage: test needed
Components: Library (Lib) Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: belopolsky, flox, vstinner
Priority: normal Keywords: buildbot

Created on 2011-11-01 16:56 by flox, last changed 2011-11-24 15:17 by vstinner. This issue is now closed.

Messages (3)
msg146794 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2011-11-01 16:56
On builder "x86 FreeBSD 7.2 3.x" :

======================================================================
FAIL: test_tzset (test.test_time.TimeTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/test_time.py", line 246, in test_tzset
    self.assertTrue(time.tzname[0] == 'AEST', str(time.tzname[0]))
AssertionError: False is not true : EST


(See also issue #13309 for tzname on Gentoo)
msg147264 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2011-11-07 23:17
Maybe it is related.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=93810

Ambiguous timezone names (AEST vs EST)
msg148261 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-11-24 15:17
Duplicate of #11886.
History
Date User Action Args
2011-11-24 15:17:17vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg148261

resolution: duplicate
2011-11-07 23:17:11floxsetmessages: + msg147264
2011-11-01 16:56:43floxcreate