classification
Title: Multiprocessing Pool.map_async() does not have an error_callback parameter
Type: Stage: patch review
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Jakub.Gedeon, docs@python, nailor, orsenthil, petri.lehtinen, python-dev
Priority: normal Keywords: needs review, patch

Created on 2011-10-10 23:37 by Jakub.Gedeon, last changed 2011-11-02 18:04 by orsenthil. This issue is now closed.

Files
File name Uploaded Description Edit
issue13147.patch nailor, 2011-11-02 07:50
Messages (6)
msg145316 - (view) Author: Jakub Gedeon (Jakub.Gedeon) Date: 2011-10-10 23:37
Multiprocessing Pool.map_async() does not have an error_callback paramter as described here http://docs.python.org/library/multiprocessing.html#multiprocessing.pool.multiprocessing.Pool.map_async

I assume this is an old configuration that no longer works... I tried to call that parameter by name and I got a Type Error, plus the actual documentation does not mention it at all (and it is missing from similar functions). Recommend it be removed from the documentation, or else better described and implemented.
msg146832 - (view) Author: Jyrki Pulliainen (nailor) * Date: 2011-11-02 07:41
Python 3.x seems to have the error_callback parameter on all *_async operations. However, 2.7 lacks it. I think adding the actual error_callback would be deemed as a new feature, so the right thing would just be removing the documentation.

I'll whip up a patch to remove this from the documentation
msg146833 - (view) Author: Jyrki Pulliainen (nailor) * Date: 2011-11-02 07:50
Patch attached. This patch removes the error_callback from 2.7's documentation.
msg146834 - (view) Author: Jyrki Pulliainen (nailor) * Date: 2011-11-02 07:53
Also: note that 2.6 does not document this error_callback, so the issue is present only in 2.7
msg146862 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2011-11-02 18:03
New changeset 37e34a983d6d by Senthil Kumaran in branch '2.7':
Fix Issue13147 - Correct the Multiprocessing Pool.map_async method signature.
http://hg.python.org/cpython/rev/37e34a983d6d
msg146863 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2011-11-02 18:04
Thanks for the report, Jakub and for the patch, Jyrki
History
Date User Action Args
2011-11-02 18:04:53orsenthilsetstatus: open -> closed

nosy: + orsenthil
messages: + msg146863

resolution: fixed
2011-11-02 18:03:44python-devsetnosy: + python-dev
messages: + msg146862
2011-11-02 07:55:08petri.lehtinensetkeywords: + needs review
nosy: + petri.lehtinen

stage: patch review
2011-11-02 07:53:06nailorsetmessages: + msg146834
2011-11-02 07:50:01nailorsetfiles: + issue13147.patch
keywords: + patch
messages: + msg146833
2011-11-02 07:41:34nailorsetnosy: + nailor
messages: + msg146832
2011-10-10 23:37:50Jakub.Gedeoncreate