classification
Title: Be more generic when identifying the Windows main dir in installation doc
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: docs@python Nosy List: brian.curtin, docs@python, eric.araujo, loewis, sandro.tosi, terry.reedy, tim.golden
Priority: normal Keywords:

Created on 2011-09-22 21:31 by sandro.tosi, last changed 2014-05-06 19:30 by tim.golden. This issue is now closed.

Messages (6)
msg144422 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2011-09-22 21:31
Given I have no knowledge of the windows system, I'm just proxying http://mail.python.org/pipermail/docs/2011-September/005793.html :

>>>
Under: http://docs.python.org/install/index.html#inst-how-install-works


It notes "Windows	prefix\Lib\site-packages	C:\PythonXY\Lib\site-packages"
for default values on Windows.

In the paragraph following the table is the text: "prefix and
exec-prefix stand for the directories that Python is installed to, and
where it finds its libraries at run-time. They are always the same
under Windows, and very often the same under Unix and Mac OS X. "

I don't know if it's hardcoded into Python distributions to use C, but
it's not correct. The correct way to identify what most people think
of as C is via the %SYSTEMROOT% environment variable, so the path
described would be "%SYSTEMROOT%\PythonXY\Lib\site-packages"

(This is still not the correct way to do things on Windows, but it at
least shouldn't break on systems with a %SYSTEMROOT% other than C.
I've seen configurations like that on systems which boot multiple
versions of Windows.)
<<<
msg144473 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2011-09-23 19:50
Windows does not require that executables be on any particular 'drive'.
msg144555 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-09-27 16:29
Terry, are you saying that the report is not a bug or that some part of the message is valid and some other part not?  I can’t see clearly what I should do.

Sandro: You can nosy me to all bugs for distutils docs: Doc/distutils, Doc/install, Doc/packaging, Doc/library/packaging.* (and also related docs like site, using, sysconfig)
msg144556 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2011-09-27 19:17
I said exactly what I said ;-). Upon looking further (following the links), I see that 'install' refers to the disutils setup program install command option. What you should do is make the doc accurate and clear.

What 'accurate' means is for you to say, but not having used install, the doc is not too clear to me. The table headings 'Standard installation location' (of what?) and 'Default value' (for what program?) both seem a bit ambiguous, or rather they seem reversed to me. I would label the columns 'Default module directory' and 'Standard Python location'.

That said, I hope that the actual default module installation directory for install is the actual site-packages directory on my machine, based on where I actually put python, and not the non-existent standard location, which I did not use but which is what the text seems to say (but which would be a behavior design bug to me).

MARTIN: below is the question for you.

The issue raised by the off-tracker OP, Michael Mol, is a different one about how the .msi installer works and whether this doc is correctly describing how it works. The question is whether the default python install directory built into pythonxy...msi is literally "C:\PythonXY\Lib\site-packages" or whether it is actually "%SYSTEMROOT%\PythonXY\Lib\site-packages". Mr. Mol claims that the latter, or something else (unspecified), is better.
msg145244 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-10-09 09:14
> The table headings 'Standard installation location' (of what?)
Of software projects using distutils.

> and 'Default value' (for what program?)
For a CPython without changes to the default build configuration.

> both seem a bit ambiguous, or rather they seem reversed to me. I
> would label the columns 'Default module directory' and 'Standard
> Python location'.
Well, no: the first column does not contain real paths, but templates with placeholders like prefix and X.Y.  The second column gives the path with the placeholders replaced by their default value.

> That said, I hope that the actual default module installation
> directory for install is the actual site-packages directory on
> my machine, based on where I actually put python,
Yes.

> and not the non-existent standard location, which I did not use
> but which is what the text seems to say (but which would be a
> behavior design bug to me).
“Default” means “if you haven’t made any change to the build/install configuration of Python”.

Do these replies make sense?  If so, I can rephrase them as a doc patch.
msg218009 - (view) Author: Tim Golden (tim.golden) * (Python committer) Date: 2014-05-06 19:30
This is essentially superseded now by the work done over on distutils-sig and by the PyPA. (Which has included considering the differeng terminology of installation vs other paths on Windows vs Unix).
History
Date User Action Args
2014-05-06 19:30:39tim.goldensetstatus: open -> closed
resolution: wont fix
messages: + msg218009

stage: needs patch -> resolved
2011-10-09 09:14:26eric.araujosetmessages: + msg145244
2011-09-27 19:17:14terry.reedysetnosy: + loewis
messages: + msg144556
2011-09-27 16:29:00eric.araujosetnosy: + eric.araujo
messages: + msg144555
2011-09-23 19:50:24terry.reedysetnosy: + terry.reedy
messages: + msg144473
2011-09-22 21:31:50sandro.tosicreate