classification
Title: unhandled exception at install
Type: crash Stage:
Components: Installation Versions: Python 2.7
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: brian.curtin, georg.brandl, jorge.seifert, loewis
Priority: normal Keywords:

Created on 2011-09-17 12:06 by jorge.seifert, last changed 2013-03-28 10:19 by georg.brandl. This issue is now closed.

Messages (10)
msg144182 - (view) Author: jorge.seifert (jorge.seifert) Date: 2011-09-17 12:06
Unhandled exception just at when start to install on windows 2003
msg144183 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2011-09-17 12:08
Can you please give ANY information on what exactly you were installing, and what the exception was? Otherwise this report is useless.
msg144186 - (view) Author: jorge.seifert (jorge.seifert) Date: 2011-09-17 14:14
The message I get after it is:

undandled win32 exception occurred in msiexec [2376]

I am tryin to install on windows server 2003
msg144208 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2011-09-17 16:35
And which version, exactly?  Which file, downloaded from where?
msg144223 - (view) Author: jorge.seifert (jorge.seifert) Date: 2011-09-17 23:58
Version 2,7,2
file python 2.7.2.msi
downloaded from this website
msg144224 - (view) Author: jorge.seifert (jorge.seifert) Date: 2011-09-18 00:10
'msiexec.exe': Loaded 'C:\WINDOWS\system32\msiexec.exe', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\ntdll.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\kernel32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\advapi32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\rpcrt4.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\secur32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\user32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\gdi32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\msvcrt.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\ole32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\msi.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\imm32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.3790.4770_x-ww_05FDF087\comctl32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\shlwapi.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\Documents and Settings\All Users\Datos de programa\Real\RealPlayer\BrowserRecordPlugin\Chrome\Hook\rpchrome10browserrecordhelper.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.30729.6161_x-ww_31a54e43\msvcr90.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\shell32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.30729.6161_x-ww_31a54e43\msvcp90.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\msctf.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\Archivos de programa\ScanSoft\OmniPageSE4\OpHookSE4.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\version.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\oleaut32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\apphelp.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\msctfime.ime', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\uxtheme.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\sfc.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\sfc_os.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\wintrust.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\crypt32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\msasn1.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\imagehlp.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\netapi32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\rsaenh.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\psapi.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\userenv.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\cryptnet.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\wldap32.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\sensapi.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\clbcatq.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\comres.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\xpsp2res.dll', Binary was not built with debug information.
'msiexec.exe': Loaded 'C:\WINDOWS\system32\mscoree.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\mscoreei.dll', Cannot find or open the PDB file
'msiexec.exe': Loaded 'C:\WINDOWS\system32\msihnd.dll', Cannot find or open the PDB file
Unhandled exception at 0x60d35efa in msiexec.exe: 0xC0000005: Access violation reading location 0x00000020.
First-chance exception at 0x60d35efa in msiexec.exe: 0xC0000005: Access violation reading location 0x00000020.
Unhandled exception at 0x60d35efa in msiexec.exe: 0xC0000005: Access violation reading location 0x00000020.
First-chance exception at 0x60d35efa in msiexec.exe: 0xC0000005: Access violation reading location 0x00000020.
The thread 'Win32 Thread' (0xa88) has exited with code 0 (0x0).
Unhandled exception at 0x60d35efa in msiexec.exe: 0xC0000005: Access violation reading location 0x00000020.
msg144230 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2011-09-18 05:40
Thanks!
msg144249 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2011-09-18 18:26
Can you please run

msiexec /i python2.7.2.msi /l*v python.log

and compress and attach the resulting python.log?

I'm skeptical though that we will be able to do anything about this issue.
msg178029 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2012-12-24 03:42
Unassigning myself. Jorge - are you still able to reproduce this, and if so, are you able to capture the log as mentioned by Martin?
msg185421 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2013-03-28 10:19
Closing due to lack of response.
History
Date User Action Args
2013-03-28 10:19:12georg.brandlsetstatus: pending -> closed

messages: + msg185421
2012-12-24 19:26:49brian.curtinsetstatus: open -> pending
2012-12-24 03:42:09brian.curtinsetassignee: brian.curtin ->
messages: + msg178029
2011-09-18 18:26:11loewissetmessages: + msg144249
2011-09-18 05:40:33georg.brandlsetassignee: brian.curtin

messages: + msg144230
nosy: + loewis, brian.curtin
2011-09-18 00:10:44jorge.seifertsetmessages: + msg144224
2011-09-17 23:58:12jorge.seifertsetmessages: + msg144223
2011-09-17 16:35:03georg.brandlsetmessages: + msg144208
2011-09-17 14:14:32jorge.seifertsetmessages: + msg144186
2011-09-17 12:08:15georg.brandlsetnosy: + georg.brandl
messages: + msg144183
2011-09-17 12:06:14jorge.seifertcreate