classification
Title: MSI installer does not pass values as SecureProperty from UI
Type: behavior Stage: resolved
Components: Installation, Windows Versions: Python 3.0, Python 2.4, Python 2.6, Python 2.5
process
Status: closed Resolution: out of date
Dependencies: Superseder: msi installs to the incorrect location (C drive)
View: 2271
Assigned To: loewis Nosy List: ajaksu2, georg.brandl, loewis, matthewleslie, music
Priority: normal Keywords:

Created on 2005-09-22 17:27 by matthewleslie, last changed 2009-04-26 01:30 by ajaksu2. This issue is now closed.

Files
File name Uploaded Description Edit
pyinstall.zip matthewleslie, 2005-09-29 10:37 Zipped MIS log file - installs to C:
Messages (11)
msg26357 - (view) Author: Matthew Leslie (matthewleslie) Date: 2005-09-22 17:27
This appears to be an instance of the problem
documented here:

http://tinyurl.com/82dt2
aka:
http://groups.google.nl/group/microsoft.public.platformsdk.msi/browse_thread/thread/2359de6cc83c3b2f/67ef84f8f0ba99db?lnk=st&q=%22Ignoring+disallowed+property%22+msi&rnum=4&hl=nl#67ef84f8f0ba99db

I ran into problems installing as a 'power user' but
not an admin on a windows XP box. The program was
always installing in C:/

Running msiexec with logging revealed the following lines:

MSI (s) (48:F8) [18:15:47:990]: Ignoring disallowed
property X
MSI (s) (48:F8) [18:15:47:990]: Ignoring disallowed
property TARGETDIR
MSI (s) (48:F8) [18:15:47:990]: Ignoring disallowed
property DLLDIR
MSI (s) (48:F8) [18:15:47:990]: Ignoring disallowed
property USERNAME
MSI (s) (48:F8) [18:15:47:990]: Ignoring disallowed
property COMPANYNAME
MSI (s) (48:F8) [18:15:47:990]: Ignoring disallowed
property SOURCEDIR
MSI (s) (48:F8) [18:15:47:990]: Ignoring disallowed
property ROOTDRIVE

Values were not being passed from the UI to the actual
installation script. This is apparently a known issue
which can be resolved by using  SecureCustomProperties
to pass them from the UI to the installer, as
documented in the link above.
msg26358 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2005-09-25 04:35
Logged In: YES 
user_id=21627

What specific problems did you run into?
msg26359 - (view) Author: Matthew Leslie (matthewleslie) Date: 2005-09-25 11:27
Logged In: YES 
user_id=597393

Yes, I forgot to mention that this means the installer always 
tries to put pythons root directory in your root C:\  directory, 
which is in any case messy, and in my case, a showstopper, 
as I need to install to another drive.
msg26360 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2005-09-27 14:09
Logged In: YES 
user_id=21627

Unfortunately, I cannot reproduce the problem. On my 
system, the power user can install to a different drive or 
directory just fine, and I get no message "Ignoring disallowed 
property".

What operating system are you using?

Can you please attach a compressed copy of the log?
msg26361 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2005-09-27 19:51
Logged In: YES 
user_id=21627

In additon, can you please provide the settings under

HKEY_CURRENT_USER\Software\Policies\Microsoft\
     Windows\Installer

and

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\
     Windows\Installer

on your machine?

If possible, can you try setting EnableUserControl to
(DWORD)1 under the HKLM key?
msg26362 - (view) Author: Matthew Leslie (matthewleslie) Date: 2005-09-29 10:37
Logged In: YES 
user_id=597393

I am running windows XP, and am logging in

HKLM policies:
AlwaysInstallElevated 1
EnableAdminTSRemote 1

HKCurrentUser policies:
AlwaysInstallElevated 1

Sadly, I am not allowed to change HKLM keys on this machine.



msg26363 - (view) Author: Matthew Leslie (matthewleslie) Date: 2005-09-29 10:40
Logged In: YES 
user_id=597393

I have attached the install log
msg26364 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2005-09-29 16:14
Logged In: YES 
user_id=21627

Thanks. Unfortunately, this logfile appears to start too
late. Can you please recreate it with

msiexec /i python-2.4.x.msi /l*v python.log

Are you being asked whether this is a per-user or
per-machine install? If yes, what is your response?

I'm still puzzled as to what is causing the problem here.
msg60219 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-01-19 19:32
There seems to be a related log at #1565468.
msg69729 - (view) Author: Ben Beasley (music) Date: 2008-07-15 23:43
http://bugs.python.org/issue1298962 appears to be a duplicate, with some
more recent activity.
msg86587 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-04-26 01:30
Fixed in r66305.
History
Date User Action Args
2009-04-26 01:30:12ajaksu2setstatus: open -> closed

superseder: msi installs to the incorrect location (C drive)

nosy: + ajaksu2
messages: + msg86587
resolution: out of date
stage: resolved
2008-07-15 23:45:09musicsetcomponents: + Windows
2008-07-15 23:44:34musicsettype: behavior
2008-07-15 23:44:08musicsetversions: + Python 2.6, Python 2.5, Python 2.4, Python 3.0
2008-07-15 23:43:02musicsetnosy: + music
messages: + msg69729
2008-01-19 19:32:01georg.brandlsetnosy: + georg.brandl
messages: + msg60219
2005-09-22 17:27:07matthewlesliecreate