classification
Title: pysetup doesn’t work for the docutils project
Type: Stage: resolved
Components: Distutils2 Versions: Python 3.3, 3rd party
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: tarek Nosy List: alexis, brett.cannon, eric.araujo, ncoghlan, tarek
Priority: normal Keywords:

Created on 2011-09-07 16:12 by eric.araujo, last changed 2011-11-24 14:20 by eric.araujo. This issue is now closed.

Messages (3)
msg143695 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-09-07 16:12
I tried to run “pysetup metadata” in a docutils source directory but the program failed, because packaging tries to import docutils and it picks up the 2.x version in the local directory.

The import chain is: pysetup → packaging.run → packaging.metadata → docutils

I could edit sys.path in pysetup, but that would mean that people calling “python3.y -m packaging.run” would not get the fix.  Another idea would be to catch both ImportError and SyntaxError when packaging.metadata tries to import docutils, but it would be better to find the 3.x version of docutils in site-packages if it exists.

What do you import experts think?
msg148195 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-11-23 17:18
Due to the same reason, it’s also not possible to run “pysetup3.1 metadata” in the distutils2 repo, or “pysetup2.4 metadata” in the distutils2-python3 repo.
msg148255 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-11-24 14:20
This is a problem on my side, not in distutils2.  My pysetupX.Y scripts are just shell one-liners of this form:

  PYTHONPATH=~/path/to/d2 pythonX.Y -m distutils2.run "$@"

Because of sys.path initialization, d2 tried to import docutils from the working directory instead of the version in site-packages.  If I install d2 and run the installed pysetup script, d2 and docutils are imported from site-packages and everything is fine.
History
Date User Action Args
2011-11-24 14:20:10eric.araujosetstatus: open -> closed
resolution: not a bug
messages: + msg148255

stage: resolved
2011-11-23 17:18:50eric.araujosetmessages: + msg148195
2011-09-07 16:12:47eric.araujocreate