classification
Title: New module for terminal utilities
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: eric.araujo
Priority: normal Keywords:

Created on 2011-09-06 16:37 by eric.araujo, last changed 2011-09-12 16:07 by eric.araujo. This issue is now closed.

Messages (2)
msg143629 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-09-06 16:37
It was suggested in #7798 to make the pager functions from pydoc public.  I can’t find a good place to put them, so I think we could add a new module with terminal-related utilities.  It could contain the pager functions, progress bars (there are many implementations to be compared), ANSI and Windows color codes (reimplemented over and over again), etc.

This may require a run through python-ideas and/or -dev, but I’m opening a bug for the record.
msg143915 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2011-09-12 16:07
Copied from msg143857 (Raymond Hettinger):

> Resist the urge to fatten APIs until you're sure that:
> * they are needed
> * they are well developed (many internal utils fail this test)
> * they are worth the extra time it takes to learn what is in a module (adding rarely needed
> tools has the side-effect of obscuring things people actually need)
> [...]
> The pager functions are interesting and non-trivial.  Before making them public in the
> standard library though, it would be best if it had some life as third-party module to let
> it mature (i.e. making sure it works as well in other contexts as it does in pydoc).

I’m thus closing this request.  Someone can run with the idea, publish experiments on PyPI, gather feedback from python-ideas, and we’ll see about stdlib inclusion when the time is right.
History
Date User Action Args
2011-09-12 16:07:41eric.araujosetstatus: open -> closed
resolution: not a bug
messages: + msg143915

stage: resolved
2011-09-06 16:37:27eric.araujocreate