classification
Title: test_io.test_interrupte[r]d* blocks on OpenBSD
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: neologix, pitrou, rpointel, vstinner
Priority: normal Keywords:

Created on 2011-09-05 19:51 by rpointel, last changed 2012-02-28 07:37 by neologix. This issue is now closed.

Files
File name Uploaded Description Edit
patch-Lib_test_test_io_py rpointel, 2011-09-05 19:51 patch file to skip blocking tests in test_io.py
Messages (3)
msg143558 - (view) Author: Remi Pointel (rpointel) * Date: 2011-09-05 19:51
Hi,

these tests block on OpenBSD:

-test_interrupted_write_unbuffered()
-test_interrupted_write_buffered()
-test_interrupted_write_text()
-test_interrupterd_read_retry_buffered()
-test_interrupterd_read_retry_text()
-test_interrupterd_write_retry_buffered()
-test_interrupterd_write_retry_text()

I have a patch which skip these tests, to have a full test_io.py regress tests but I think it's not the proper solution.

Thanks for your help,

Remi.
msg143577 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-09-06 00:11
It looks similar to issue #12905: yet another threads+signals issue?
msg154536 - (view) Author: Remi Pointel (rpointel) * Date: 2012-02-28 07:13
I think we could close this bug because it's du to the pthread library on OpenBSD and not Python.
We are switching to rthreads and I can't reproduce this bug.

Thanks for your help and sorry for the delay.
History
Date User Action Args
2012-02-28 07:37:18neologixsetstatus: open -> closed
resolution: not a bug
stage: patch review -> resolved
2012-02-28 07:13:33rpointelsetmessages: + msg154536
2011-09-06 00:11:51vstinnersetmessages: + msg143577
2011-09-05 22:22:38pitrousetversions: + Python 2.7, Python 3.3
nosy: + pitrou, vstinner, neologix

components: + Tests
type: behavior
stage: patch review
2011-09-05 19:51:54rpointelcreate