classification
Title: Rearrange descriptions of builtin types in the Library reference
Type: Stage: resolved
Components: Documentation Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, ezio.melotti, gvanrossum, ncoghlan
Priority: normal Keywords:

Created on 2011-08-31 22:42 by ncoghlan, last changed 2011-09-01 01:12 by ezio.melotti. This issue is now closed.

Messages (8)
msg143284 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2011-08-31 22:42
Section 4 of the Standard Library reference currently includes the two following sections (amongst others):

4.6. Sequence Types — str, bytes, bytearray, list, tuple, range
4.9. memoryview type

This is crazy - memoryview, a fairly niche type, gets its own second tier section on the main table of contents, while str, one of the most important types in Python, is tucked away under the generic "Sequence Type" heading?

I propose that these sections be rearranged as:

4.6 Sequence Types - list, tuple, range
4.7 Text Types - str
4.8 Binary Data Types - bytes, bytearray, memoryview

The Set Types and Mapping Types sections would slide down to sections 4.9 and 4.10 to make room for the two new sections.
msg143285 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2011-08-31 22:45
Better titles for the proposed new sections:

4.7 Text Data - str
4.8 Binary Data - bytes, bytearray, memoryview
msg143286 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2011-08-31 22:56
I agree on the subdivision, but I think they should still be grouped together somehow, since these all really *do* share some interfaces: __getitem__ (with slicing), __iter__, __len__, at least; arguably __contains__; probably some others (see collections/abc.py).
msg143287 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2011-08-31 23:05
Putting the new sections on tier 2 makes a big difference in discoverability, since that's the lowest level the main ToC page shows. Perhaps just including the phrase "Sequence Type" in the new section titles would provide enough logical grouping?

Something like:

4.6 Sequence Types - list, tuple, range
4.7 Text Sequence Type - str
4.8 Binary Data Sequence Types - bytes, bytearray, memoryview
msg143288 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2011-08-31 23:16
That sounds fine. Or list most of them at tier 2:

4.6 Sequence Types - list, tuple, range, str, bytes and friends
  4.6.1 Sequence containers - list, tuple, range
  4.6.2 Text Sequence Type - str
  4.6.3 Binary Data Sequence Types - bytes, bytearray, memoryview

Although including range() here feels a bit odd? (It's a much more
specialized type -- actually the same can be said for memoryview.)
msg143290 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2011-09-01 00:58
'Sequence Types - list, tuple, str, bytes, etc' *might* work, but I think part of the problem is that str's brevity is actually a downside in this case. I know I missed it when I was scanning the ToC earlier (I wanted to check if the internal Unicode repr for narrow builds was documented at all - it doesn't appear to be).
msg143291 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2011-09-01 01:09
How about "list, tuple, text and binary strings" ?
msg143292 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2011-09-01 01:12
I believe this is a duplicate of #4966.
History
Date User Action Args
2011-09-01 01:12:28ezio.melottisetstatus: open -> closed

nosy: + ezio.melotti
messages: + msg143292

resolution: duplicate
stage: needs patch -> resolved
2011-09-01 01:09:55gvanrossumsetmessages: + msg143291
2011-09-01 00:58:27ncoghlansetmessages: + msg143290
2011-08-31 23:16:48gvanrossumsetmessages: + msg143288
2011-08-31 23:05:34ncoghlansetmessages: + msg143287
2011-08-31 22:56:31gvanrossumsetnosy: + gvanrossum
messages: + msg143286
2011-08-31 22:45:55ncoghlansetmessages: + msg143285
2011-08-31 22:43:21ncoghlansetstage: needs patch
2011-08-31 22:43:02ncoghlansettitle: Rearrange descriptions of builtin types -> Rearrange descriptions of builtin types in the Library reference
2011-08-31 22:42:40ncoghlancreate