classification
Title: setp.py error "The process cannot access the file ..."
Type: behavior Stage:
Components: Distutils, Windows Versions:
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: loewis Nosy List: loewis, tim.golden, uweber4711
Priority: normal Keywords:

Created on 2007-10-16 07:29 by uweber4711, last changed 2009-02-16 21:46 by loewis. This issue is now closed.

Files
File name Uploaded Description Edit
py_soft.zip uweber4711, 2007-11-26 09:49
dos_window.jpg uweber4711, 2007-11-26 09:49
Messages (5)
msg56496 - (view) Author: Ulrich Weber (uweber4711) Date: 2007-10-16 07:29
When creating a windows installer using setup.py an error message is 
displayed: "error: c:\docume~1\uweber\loca1s~1\temp\tmppnj1gz .zip: The 
process cannot access the file because it is being used by another 
process". The installer is created nevertheless and seems to work fine. 
I am using Python 2.5.1 on WinXP SP2.
msg57808 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-11-24 17:28
Can you provide a setup.py that allows to reproduce this error?
msg57840 - (view) Author: Ulrich Weber (uweber4711) Date: 2007-11-26 09:49
Hi!

Attached you will find my setup.py with all other files required.

(See attached file: py_soft.zip)

Running the procedure "run_setup.cmd" in my environment from a DOS window
will produce an error message as shown in the screenshot attached.

(See attached file: dos_window.jpg)

Note: The installer is created properly nevertheless.

Regards
U. Weber

Dr. Ulrich Weber

CSC
Delivery Test & Configuration Management

Eutelisplatz 2
40878 Ratingen
Germany
Phone: +49.2102.165.7255
Fax: +49.2102.165.7200
E-Mail: uweber@csc.com
Internet: http://www.de.csc.com

CSC ist Sponsor des Team CSC.

CSC Deutschland Solutions GmbH
Registered Office: Abraham-Lincoln-Park 1, 65189 Wiesbaden, Germany
Board of Directors: Gerhard Fercho (Chairman), Werner Martin Deda, Peter
Schmidt
Chairman of the Supervisory Board: Dr. Jürgen Than
Registered in Germany: HRB 22374

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

This is a PRIVATE message. If you are not the intended recipient, please
delete without copying and kindly advise us by e-mail of the mistake in
delivery.
NOTE: Regardless of content, this e-mail shall not operate to bind CSC to
any order or other contract unless pursuant to explicit written agreement
or government initiative expressly permitting the use of e-mail for such
purpose.
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

             "Martin v. Löwis"                                             
             <report@bugs.pyth                                             
             on.org>                                                    To 
                                       Ulrich Weber/PLZ/CSC@CSC            
             24.11.2007 18:28                                           cc 

                                                                   Subject 
             Please respond to         [issue1285] setp.py error "The      
                  Tracker              process cannot access the file ..." 
             <report@bugs.pyth                                             
                  on.org>                                                  

Martin v. Löwis added the comment:

Can you provide a setup.py that allows to reproduce this error?

__________________________________
Tracker <report@bugs.python.org>
<http://bugs.python.org/issue1285>
__________________________________
msg82249 - (view) Author: Tim Golden (tim.golden) * (Python committer) Date: 2009-02-16 16:29
Can't reproduce under Python 2.6 or Python 2.5.2. Likelihood is a virus
checker / indexer process.
msg82275 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-02-16 21:46
Closing as "works for me", then.
History
Date User Action Args
2009-02-16 21:46:15loewissetstatus: open -> closed
resolution: works for me
messages: + msg82275
2009-02-16 16:29:14tim.goldensetnosy: + tim.golden
messages: + msg82249
2009-02-16 16:23:49akitadasetcomponents: + Windows
2007-11-26 09:49:35uweber4711setfiles: + py_soft.zip, dos_window.jpg
messages: + msg57840
2007-11-24 17:28:31loewissetmessages: + msg57808
2007-11-24 14:02:18georg.brandlsetassignee: loewis
nosy: + loewis
2007-10-16 07:29:09uweber4711create