classification
Title: IDLE does not start if windows environment variable containing 'German Umlaute: äöü' exists
Type: crash Stage:
Components: IDLE Versions: Python 3.0
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, kbk, reto
Priority: normal Keywords:

Created on 2007-10-11 11:30 by reto, last changed 2007-10-28 19:20 by kbk. This issue is now closed.

Messages (3)
msg56342 - (view) Author: Reto Wehrli (reto) Date: 2007-10-11 11:30
C:\devtools\Python30\Lib\idlelib>set
...
eRoomOfflineFiles=Z:\Documents and Settings\tgdwere3\My Documents\eRoom
Dateien
für die Offline-Bearbeitung\
...

C:\devtools\Python30\Lib\idlelib>..\..\python.exe idle.pyw
object  : UnicodeDecodeError('utf8', b'Z:\\Documents and
Settings\\tgdwere3\\My
Documents\\eRoom Dateien f\xfcr die Offline-Bearbeitung\\', 63, 69, 'u
nsupported Unicode code range')
type    : UnicodeDecodeError
refcount: 4
address : 00B825B0
lost sys.stderr

after removing the env variable idle starts
msg56864 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-10-27 22:06
Confirmed!

Python 3.0 doesn't start at all on Windows when an environment variable
with non ASCII chars is present. This bug is related to
http://bugs.python.org/issue1342.

However on Linux Python 3.0 can handle unicode characters in paths and
environ vars fine.

$ UNITEST="umlauts äöü ß " ./python -c "import os;
print(os.environ['UNITEST'])"
umlauts äöü ß
msg56891 - (view) Author: Kurt B. Kaiser (kbk) * (Python committer) Date: 2007-10-28 19:20
I believe this is a duplicate of
http://bugs.python.org/issue1342
and not related to IDLE.
History
Date User Action Args
2007-10-28 19:20:02kbksetstatus: open -> closed
resolution: duplicate
messages: + msg56891
nosy: + kbk
2007-10-27 22:06:33christian.heimessetnosy: + christian.heimes
messages: + msg56864
severity: normal -> urgent
2007-10-11 11:30:37retocreate