classification
Title: define OpenBSD in configure.in if Py_ENABLE_SHARED == 1
Type: behavior Stage: resolved
Components: Installation Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: libpython.so not built on OpenBSD
View: 12560
Assigned To: Nosy List: rpointel, skrah
Priority: normal Keywords:

Created on 2011-07-20 09:04 by rpointel, last changed 2011-07-20 12:24 by skrah. This issue is now closed.

Messages (2)
msg140725 - (view) Author: Remi Pointel (rpointel) * Date: 2011-07-20 09:04
Hi,

Could you define OpenBSD in enable_shared section of the configure.in ?

I just tested with Python 3.2.1, but it could be usefull to add it in the other versions of Python 3.x.

This is the diff which seems to work :

--- configure.in.orig   Sat Jul  9 08:58:56 2011
+++ configure.in        Wed Jul 20 10:19:37 2011
@@ -755,7 +755,7 @@
              PY3LIBRARY=libpython3.so
          fi
           ;;
-    Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*)
+    Linux*|GNU*|NetBSD*|FreeBSD*|OpenBSD*|DragonFly*)
          LDLIBRARY='libpython$(LDVERSION).so'
          BLDLIBRARY='-L. -lpython$(LDVERSION)'
          RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}

Thanks a lot,

Remi.
msg140728 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2011-07-20 12:24
This is a duplicate of #12560.
History
Date User Action Args
2011-07-20 12:24:09skrahsetstatus: open -> closed

superseder: libpython.so not built on OpenBSD
type: behavior

nosy: + skrah
messages: + msg140728
resolution: duplicate
stage: resolved
2011-07-20 09:04:19rpointelcreate