classification
Title: spurious output in test_warnings
Type: behavior Stage: needs patch
Components: Tests Versions: Python 3.2, Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: vstinner Nosy List: ezio.melotti, pitrou, vstinner
Priority: low Keywords:

Created on 2011-07-08 21:54 by pitrou, last changed 2013-07-02 00:36 by vstinner. This issue is now closed.

Messages (2)
msg140043 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-07-08 21:54
$ ./python -m test test_warnings
[1/1] test_warnings
test.test_warnings:553: UserWarning: test

Also, I don't understand how test_filename_none is supposed to check for issue #12467 (it doesn't use a subprocess).
msg191703 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-06-23 14:02
I cannot reproduce this isuse, was it fixed?

$ ./python -m test test_warnings
[1/1] test_warnings
1 test OK.

> Also, I don't understand how test_filename_none is supposed to check for issue #12467 (it doesn't use a subprocess).

You don't need a subprocess to reproduce the issue, you just have to emit a warning with __file__=None. At shutdown, __file__ is set to None by Py_Finalize, whereas a warning is emitted because a file was not closed explicitly.
History
Date User Action Args
2013-07-02 00:36:30vstinnersetstatus: open -> closed
resolution: out of date
2013-06-23 14:02:05vstinnersetmessages: + msg191703
2013-01-28 11:40:05ezio.melottisetnosy: + ezio.melotti

versions: + Python 3.4
2011-07-08 21:54:47pitroucreate