classification
Title: Fail codecs.lookup() on 'mbcs' and 'tactis'
Type: enhancement Stage:
Components: Documentation, Unicode Versions: Python 2.4
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: lemburg Nosy List: ajaksu2, lemburg, liturgist, loewis, vstinner
Priority: normal Keywords:

Created on 2005-08-04 14:11 by liturgist, last changed 2009-02-16 20:02 by vstinner. This issue is now closed.

Messages (10)
msg25983 - (view) Author: liturgist (liturgist) Date: 2005-08-04 14:11
$ python
Python 2.4.1 (#1, May 16 2005, 15:19:29)
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)] on linux2
Type "help", "copyright", "credits" or "license" for
more information.
>>> import codecs
>>> codecs.lookup('ascii')
(<built-in function ascii_encode>, <built-in function
ascii_decode>, <class encodings.ascii.StreamReader at
0xb7f1302c>, <class encodings.ascii.StreamWriter at
0xb7f82fbc>)
>>> codecs.lookup('mbcs')
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib/python2.4/encodings/__init__.py", line
96, in search_function
    globals(), locals(), _import_tail)
  File "/usr/lib/python2.4/encodings/mbcs.py", line 14,
in ?
    class Codec(codecs.Codec):
  File "/usr/lib/python2.4/encodings/mbcs.py", line 18,
in Codec
    encode = codecs.mbcs_encode
AttributeError: 'module' object has no attribute
'mbcs_encode'
>>> codecs.lookup('tactis')
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
LookupError: unknown encoding: tactis
msg25984 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2005-08-04 14:38
Logged In: YES 
user_id=38388

mbcs is only available on Windows.

I'm not sure what happened to the tactis codec - it's
possible that it never got checked in.

Do you have a reference for the tactis encoding ?
msg25985 - (view) Author: liturgist (liturgist) Date: 2005-08-04 14:55
Logged In: YES 
user_id=197677

UTF-8 is an MBCS encoding in that is is a "multiple byte
character set", right? :-)  UTF-16 is an MSCS; multiple
short character set.

There appears to have been some discussion on 'tactis' and
'tactis260' earlier in bug 854511.

http://mail.python.org/pipermail/python-bugs-list/2003-December/021394.html
msg25986 - (view) Author: liturgist (liturgist) Date: 2005-08-04 15:00
Logged In: YES 
user_id=197677

If 'mbcs' is Windows-only, then why does it appear in the
list of registered codecs in encodings.aliases.aliases on
the Linux platform?  Shouldn't it not be registered on other
platforms?
msg25987 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2005-08-06 11:56
Logged In: YES 
user_id=21627

Yes, UTF-8 is a multi-byte character set, but no, UTF-8 and
mbcs are not synonyms. See

http://docs.python.org/lib/standard-encodings.html

for the documentation. encodings.aliases.aliases is no
registration - it is an alias databse. So if somebody refers
to "dbcs", this will be aliased to "mbcs". That does not
mean "mbcs" needs to be supported - it only means "dbcs" is
not supported on Linux, either.

tactis was never part of a Python release, so its lack is
not a bug.

Closing this report as invalid.
msg25988 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2005-08-06 12:51
Logged In: YES 
user_id=38388

Reopened: this is indeed a bug - the tactis codec is
referenced in the aliases table but was never added to the
encodings package.

Either the codec will have to be added, or the alias entry
removed.
msg25989 - (view) Author: liturgist (liturgist) Date: 2005-08-06 19:04
Logged In: YES 
user_id=197677

Where is bug 854511 regarding Thai encodings?  The URL has
some discussion of this bug on TISI and ISO encodings.

http://mail.python.org/pipermail/python-bugs-list/2003-December/021394.html
msg25990 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2005-08-06 19:09
Logged In: YES 
user_id=21627

It's not a bug, it's a feature request, and it's at

http://python.org/sf/854511

I have rejected the request.
msg82196 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-02-16 00:45
The 'tactis' codec is still missing, but it's not mentioned in docs
either: http://docs.python.org/dev/library/codecs.html#id3

I'll close this one soon unless someone voices disagreement.
msg82267 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2009-02-16 20:02
It looks like few people need this codec (no message since 2005), so I 
close this feature request.

Reopen this issue if you need this codec.
History
Date User Action Args
2009-02-16 20:02:29vstinnersetstatus: open -> closed
nosy: + vstinner
resolution: remind -> rejected
messages: + msg82267
2009-02-16 00:45:42ajaksu2setnosy: + ajaksu2
type: enhancement
messages: + msg82196
components: + Documentation
2005-08-04 14:11:16liturgistcreate