classification
Title: input() does'nt strip CR
Type: behavior Stage:
Components: Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: input() has trailing carriage return on windows
View: 11272
Assigned To: Nosy List: Atsushi.Odagiri, georg.brandl
Priority: normal Keywords:

Created on 2011-07-03 11:03 by Atsushi.Odagiri, last changed 2011-07-03 11:05 by georg.brandl. This issue is now closed.

Messages (2)
msg139682 - (view) Author: Atsushi Odagiri (Atsushi.Odagiri) Date: 2011-07-03 11:03
Python 3.2 (r32:88445, Feb 20 2011, 21:30:00) [MSC v.1500 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> input()
a
'a\r'


Python 3.1.3 (r313:86834, Nov 27 2010, 17:20:37) [MSC v.1500 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> input()
a
'a'
msg139683 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2011-07-03 11:05
This is a duplicate of #11272, which will be fixed in 3.2.1.
History
Date User Action Args
2011-07-03 11:05:50georg.brandlsetstatus: open -> closed

nosy: + georg.brandl
messages: + msg139683

superseder: input() has trailing carriage return on windows
resolution: duplicate
2011-07-03 11:03:37Atsushi.Odagiricreate