classification
Title: test_import.test_failing_import_sticks() sporadic failures
Type: Stage:
Components: Tests Versions: Python 3.3
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: brett.cannon, ncoghlan, vstinner
Priority: normal Keywords:

Created on 2011-06-30 15:16 by vstinner, last changed 2013-01-03 01:47 by vstinner. This issue is now closed.

Messages (2)
msg139492 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-06-30 15:16
The following test fails sometimes. I don't know on which buildbot it occurs. The last failure is on "x86 XP-5 3.x":

======================================================================
FAIL: test_failing_import_sticks (test.test_import.ImportTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "D:\Buildslave\3.x.moore-windows\build\lib\test\test_import.py", line 185, in test_failing_import_sticks
    self.assertRaises(ZeroDivisionError, __import__, TESTFN)
AssertionError: ZeroDivisionError not raised by __import__

http://www.python.org/dev/buildbot/all/builders/x86%20XP-5%203.x/builds/3085/steps/test/logs/stdio
msg178888 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-01-03 01:47
Sporadic failure, I don't know if it was reproduced recently, and the issue has no activity since more than 6 months => I'm closing the issue.
History
Date User Action Args
2013-01-03 01:47:13vstinnersetstatus: open -> closed
resolution: out of date
messages: + msg178888
2011-12-21 12:24:51pitrousetnosy: + brett.cannon, ncoghlan
2011-06-30 15:16:20vstinnercreate