classification
Title: test_os test_ctypes test_wait3 causes test_wait3 error
Type: behavior Stage: resolved
Components: Versions: Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: ezio.melotti, nadeem.vawda, pitrou, python-dev, r.david.murray
Priority: normal Keywords: buildbot

Created on 2011-05-09 18:46 by r.david.murray, last changed 2011-05-09 23:57 by r.david.murray. This issue is now closed.

Messages (6)
msg135625 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2011-05-09 18:46
It doesn't matter which order test_os and test_ctypes run in, but if they precede test_wait3 test_wait3 will fail.  When the test is immediately re-run it passes.

The reason ought to be interesting once we figure it out :)

Tested on linux.  Doesn't appear to affect other branches.

[1/3] test_os
[2/3] test_ctypes
[3/3] test_wait3
test test_wait3 failed -- Traceback (most recent call last):
  File "/home/rdmurray/python/p33/Lib/test/fork_wait.py", line 72, in test_wait
    self.wait_impl(cpid)
  File "/home/rdmurray/python/p33/Lib/test/test_wait3.py", line 30, in wait_impl
    self.assertEqual(spid, cpid)
AssertionError: 14480 != 14487
msg135631 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-05-09 19:12
What seems to happen is that test_ctypes runs a lot of ldconfig processes, and the 10 retries in fork_wait are not enough to consume them all.
msg135633 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2011-05-09 19:17
New changeset 9e473917cbfb by Antoine Pitrou in branch 'default':
Issue #12041: Make test_wait3 more robust.
http://hg.python.org/cpython/rev/9e473917cbfb
msg135636 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-05-09 19:25
This should be fixed, can you confirm?

PS: I've opened issue12044 as one of the root causes.
msg135638 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2011-05-09 20:19
Works for me after the commit.
msg135669 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2011-05-09 23:57
Confirmed working on my box as well, and on my buildbot (where I first noticed it).
History
Date User Action Args
2011-05-09 23:57:53r.david.murraysetmessages: + msg135669
2011-05-09 20:21:11ezio.melottisetstatus: open -> closed
resolution: fixed
stage: needs patch -> resolved
2011-05-09 20:19:56ezio.melottisetstatus: pending -> open
resolution: fixed -> (no value)
messages: + msg135638

stage: resolved -> needs patch
2011-05-09 19:25:17pitrousetstatus: open -> pending
resolution: fixed
messages: + msg135636

stage: needs patch -> resolved
2011-05-09 19:17:25python-devsetnosy: + python-dev
messages: + msg135633
2011-05-09 19:16:31nadeem.vawdasetnosy: + nadeem.vawda
2011-05-09 19:12:00pitrousetnosy: + pitrou
messages: + msg135631
2011-05-09 18:48:32ezio.melottisetnosy: + ezio.melotti
2011-05-09 18:46:12r.david.murraycreate