classification
Title: problem with installing validator.nu on windows
Type: compile error Stage:
Components: Windows Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, sulakshana
Priority: normal Keywords:

Created on 2011-05-09 07:49 by sulakshana, last changed 2011-05-09 08:30 by amaury.forgeotdarc. This issue is now closed.

Messages (2)
msg135570 - (view) Author: sulakshana (sulakshana) Date: 2011-05-09 07:49
I tried following instructions given in http://about.validator.nu/#src to install validator.nu on windows. 1. changed hg clone https://bitbucket.org/validator/build build to hg.py clone https://bitbucket.org/validator/build build as HG was not getting recognised in windows. 2. when i tried to run python build/build.py all getting the following error..

pasting the entire thing... how to solve this???

C:\www\checker>python build/build.py all "hg.py" pull --update -R build https://bitbucket.org/validator/build/ Traceback (most recent call last): File "build/build.py", line 1041, in selfUpdate()

File "build/build.py", line 797, in selfUpdate hgCloneOrUpdate("build", hgRoot)

File "build/build.py", line 777, in hgCloneOrUpdate runCmd('"%s" pull --update -R %s %s%s/' % (hgCmd, mod, baseUrl, mod))

File "build/build.py", line 173, in runCmd subprocess.call(cmd)

File "C:\www\Python27\lib\subprocess.py", line 486, in call return Popen(*popenargs, **kwargs).wait()

File "C:\www\Python27\lib\subprocess.py", line 672, in init errread, errwrite)

File "C:\www\Python27\lib\subprocess.py", line 882, in _execute_child startupinfo)

WindowsError: [Error 193] %1 is not a valid Win32 application
msg135571 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2011-05-09 08:30
This is not a python issue. Please report your problem to the validator project.
History
Date User Action Args
2011-05-09 08:30:28amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg135571

resolution: not a bug
2011-05-09 07:49:39sulakshanacreate