classification
Title: Error in array concept
Type: Stage:
Components: Documentation Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: alanmcintyre, zip
Priority: normal Keywords:

Created on 2007-09-25 08:27 by zip, last changed 2007-09-25 17:30 by gvanrossum. This issue is now closed.

Messages (2)
msg56129 - (view) Author: zip (zip) Date: 2007-09-25 08:26
http://docs.python.org/tut/node5.html

The best way to remember how slices work is to think of the indices as
pointing between characters, with the left edge of the first character
numbered 0. Then the right edge of the last character of a string of n
characters has index n, for example:

--

This is not possible because counting starts from 0 so the last charater
must be n-1.
msg56131 - (view) Author: Alan McIntyre (alanmcintyre) * (Python committer) Date: 2007-09-25 12:53
The last character is n-1, but the section you quote says the *right
edge* of the last character (not the last character itself) has index n;
this seems correct in the context of the mnemonic scheme.
History
Date User Action Args
2007-09-25 17:30:40gvanrossumsetstatus: open -> closed
resolution: not a bug
2007-09-25 12:53:06alanmcintyresetnosy: + alanmcintyre
messages: + msg56131
2007-09-25 08:27:00zipcreate