classification
Title: input does not strip a trailing newline correctly on Windows
Type: behavior Stage: resolved
Components: IO, Library (Lib), Windows Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Michal.Molhanec, Trundle, brian.curtin
Priority: normal Keywords:

Created on 2011-05-01 14:58 by Michal.Molhanec, last changed 2011-05-07 00:33 by terry.reedy. This issue is now closed.

Messages (3)
msg134911 - (view) Author: Michal Molhanec (Michal.Molhanec) Date: 2011-05-01 14:58
input() returns string including trailing '\r'. IMHO the problem is not directly in the input() function which just expects that the input string was read in text mode so all of the platform specific newlines were normalized into single '\n'.
msg134912 - (view) Author: Andreas Stührk (Trundle) * Date: 2011-05-01 15:00
See issue #11272.
msg134913 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-05-01 15:00
Duplicate of #11642, #11272, and #11278.

This is fixed. It'll be released in 3.2.1
History
Date User Action Args
2011-05-07 00:33:55terry.reedysetstatus: open -> closed
2011-05-01 15:00:46brian.curtinsetnosy: + brian.curtin
messages: + msg134913

resolution: duplicate
stage: resolved
2011-05-01 15:00:30Trundlesetnosy: + Trundle
messages: + msg134912
2011-05-01 14:58:30Michal.Molhaneccreate