classification
Title: Mac OSX IDLE 3.2 does not allow entering text into toolbar windows (such as the help search box) unless all shells are closed or minimized
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.1, Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: ned.deily Nosy List: Brian.Buckley, ned.deily
Priority: normal Keywords:

Created on 2011-04-28 21:00 by Brian.Buckley, last changed 2011-04-28 23:36 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
Screen shot 2011-04-28 at 5.07.07 PM.png Brian.Buckley, 2011-04-28 21:07
Messages (2)
msg134718 - (view) Author: Brian Buckley (Brian.Buckley) Date: 2011-04-28 21:07
text enters directly to the window closest to the front rather than to the selected text box.
msg134731 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2011-04-28 23:36
Thanks for the report: yet another Aqua Tk oddity.  This one is a problem in Tk itself. It can be seen using a recent Wish 8.4 with a simple Tcl script to create a help menu.  The relevant Tk bug is here:

http://sourceforge.net/tracker/index.php?func=detail&aid=1884667&group_id=12997&atid=112997

For the record, I can reproduce the problem when using a Tkinter linked with current ActiveState Tcl/Tk 8.4.19 on either OS X 10.5 or 10.6 or with the Apple Tcl/Tk 8.4 on OS X 10.6.  All of those are Tk 8.4.19.  The problem does not appear when using the Apple-supplied Tcl/Tk 8.4 (8.4.7) on OS X 10.5.  It also does not appear when using Tkinter linked with Aqua Tk 8.5 (as is the case with the 3.2 64-bit/32-bit python.org installer).  Unfortunately, there is nothing Tkinter or IDLE can do to work around this.
History
Date User Action Args
2011-04-28 23:36:57ned.deilysetstatus: open -> closed

type: enhancement -> behavior
assignee: ned.deily
versions: + Python 3.1, Python 2.7, Python 3.3
nosy: + ned.deily

messages: + msg134731
resolution: not a bug
stage: resolved
2011-04-28 21:07:27Brian.Buckleysetfiles: + Screen shot 2011-04-28 at 5.07.07 PM.png

messages: + msg134718
2011-04-28 21:00:59Brian.Buckleycreate