classification
Title: sendmsg() and recvmsg() for C socket module
Type: enhancement Stage: resolved
Components: Extension Modules Versions: Python 3.1, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: beazley, ezio.melotti, forest, gdesmott, giampaolo.rodola, hwundram, pitrou, therve
Priority: low Keywords: patch

Created on 2005-05-03 11:19 by hwundram, last changed 2009-07-27 02:39 by ezio.melotti. This issue is now closed.

Files
File name Uploaded Description Edit
socketmodule.diff.tar.bz2 hwundram, 2005-10-26 14:57 New patches to socketmodule.{c,h} to implement recvmsg and sendmsg in an abstraction.
Messages (6)
msg48287 - (view) Author: Heiko Wundram (hwundram) Date: 2005-05-03 11:19
The following tar.bz2 contains a feature enhancement
proposal for the socket module to create wrappings of
the recvmsg and sendmsg primitives. These are sometimes
useful, especially when dealing with ancillary
messages, such as communicating the process, user and
group id of a remote process to a server for proper
identification.

These functions have so far been available in a
separate module (python-eunuchs from the twisted
project), but as they are standard POSIX and have been
available on *BSD, AIX, Linux and several other OSs for
some time they should be integrated into the core
socket module.

The attached file contains patches for configure.in the
socket module, socket.py and pyconfig.h.in. I've yet to
write a test-suite, and the documentation could use
some reworking.
msg48288 - (view) Author: Thomas Herve (therve) * Date: 2007-03-06 14:13
That's really great, it's a shame this patch didn't get much interest. Do you feel like adding test to this, it would probably psuh for its inclusion ?
msg78264 - (view) Author: David M. Beazley (beazley) Date: 2008-12-24 16:12
Bump.  This functionality seems to be needed if anyone is going to be 
messing around with advanced features of IPv6.   As it stands, the socket 
module in Python 2.6/3.0 is incomplete without this.
msg78358 - (view) Author: David M. Beazley (beazley) Date: 2008-12-27 13:00
Just a followup comment to note that adding support for 
sendmsg()/recvmsg() is what you need to do "file descriptor passing" 
between processes on Unix---another technique for writing network servers.
msg78369 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2008-12-27 16:39
The patch doesn't apply cleanly to the current trunk (which is
understandable, given the patch is from 2005). Also, some tests would be
welcome as Thomas said. And bonus points for documentation :)
msg90973 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2009-07-27 02:39
Closing this as duplicate of #6560.
History
Date User Action Args
2009-07-27 02:39:18ezio.melottisetstatus: open -> closed

nosy: + ezio.melotti
messages: + msg90973

resolution: duplicate
stage: needs patch -> resolved
2009-05-06 09:05:20gdesmottsetnosy: + gdesmott
2009-02-06 18:30:59forestsetnosy: + forest
2008-12-27 16:39:12pitrousetnosy: + pitrou
stage: needs patch
type: enhancement
messages: + msg78369
versions: + Python 3.1, Python 2.7, - Python 2.4
2008-12-27 13:00:43beazleysetmessages: + msg78358
2008-12-24 17:49:10giampaolo.rodolasetnosy: + giampaolo.rodola
2008-12-24 16:12:26beazleysetnosy: + beazley
messages: + msg78264
2008-05-21 07:30:13georg.brandllinkissue814689 superseder
2005-05-03 11:19:55hwundramcreate