classification
Title: test_ttk_guionly.test_traversal() failed on "x86 Windows7 3.x"
Type: Stage:
Components: Tests, Tkinter, Windows Versions: Python 3.3
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, vstinner
Priority: normal Keywords:

Created on 2011-04-26 00:00 by vstinner, last changed 2013-01-03 01:46 by vstinner. This issue is now closed.

Messages (4)
msg134430 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-04-26 00:00
test_ttk_guionly.test_traversal() failed on "x86 Windows7 3.x":
---------------
[120/354] test_ttk_guionly
test test_ttk_guionly failed -- Traceback (most recent call last):
  File "D:\cygwin\home\db3l\buildarea\3.x.bolen-windows7\build\lib\tkinter\test\test_ttk\test_widgets.py", line 713, in test_traversal
    self.assertEqual(self.nb.select(), str(self.child2))
AssertionError: '.116458816' != '.116461336'
- .116458816
+ .116461336
---------------
http://www.python.org/dev/buildbot/all/builders/x86%20Windows7%203.x/builds/2984/steps/test/logs/stdio
msg134431 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-04-26 00:01
Code of the test:
-----------------------------------------
class NotebookTest(unittest.TestCase):

    def setUp(self):
        support.root_deiconify()
        self.nb = ttk.Notebook(padding=0)
        self.child1 = ttk.Label()
        self.child2 = ttk.Label()
        self.nb.add(self.child1, text='a')
        self.nb.add(self.child2, text='b')



    def test_traversal(self):
        self.nb.pack()
        self.nb.wait_visibility()

        self.nb.select(0)

        support.simulate_mouse_click(self.nb, 5, 5)
        self.nb.focus_force()
        self.nb.event_generate('<Control-Tab>')
        self.assertEqual(self.nb.select(), str(self.child2)) <~~~ HERE
        ...
-----------------------------------------
msg134444 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2011-04-26 04:21
Might be a duplicate of Issue10736.
msg178886 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-01-03 01:46
Sporadic failure, I don't know if it was reproduced recently, and the issue has no activity since more than 6 months => I'm closing the issue.
History
Date User Action Args
2013-01-03 01:46:48vstinnersetstatus: open -> closed
resolution: out of date
messages: + msg178886
2011-04-26 04:21:55ned.deilysetnosy: + ned.deily
messages: + msg134444
2011-04-26 00:01:08vstinnersetmessages: + msg134431
2011-04-26 00:00:09vstinnercreate