classification
Title: gcc: unrecognized option '-n32'
Type: compile error Stage:
Components: Build Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: dmalcolm, jcea, paulg_ca, pitrou
Priority: normal Keywords:

Created on 2011-04-25 20:07 by paulg_ca, last changed 2011-04-26 14:22 by jcea. This issue is now closed.

Files
File name Uploaded Description Edit
typescript.python-2.7.1 paulg_ca, 2011-04-26 13:25 capture of configure and make
config.log paulg_ca, 2011-04-26 13:27 config.log file from configure
Messages (6)
msg134410 - (view) Author: Paul Griffith (paulg_ca) Date: 2011-04-25 20:07
In compiling Python 2.7.1 on RHEL I run into the following error message when running make.

gcc: unrecognized option '-n32'
gcc -pthread -n32  -Xlinker -export-dynamic -o python \
			Modules/python.o \
			-L. -lpython2.7 -lpthread -ldl  -lutil   -lm  
gcc: unrecognized option '-n32'
running build
running build_ext


Configured with:

./configure --prefix=/cs/local --enable-shared --libdir=/cs/local/lib64 --with-gcc=yes

GCC:

 # gcc --version
gcc (GCC) 4.4.4 20100726 (Red Hat 4.4.4-13)
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

I checked the bug tracker, but I only thing I see related deals with IRIX.
msg134424 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-04-25 22:04
Can you check CFLAGS and friends? Also, attach of output of "configure"?
msg134465 - (view) Author: Paul Griffith (paulg_ca) Date: 2011-04-26 13:25
I have included the config.log file and a script of configure and make process. CFAGS and friends are not set.
msg134466 - (view) Author: Paul Griffith (paulg_ca) Date: 2011-04-26 13:27
Here is the config.log file!
msg134467 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-04-26 13:40
> CFAGS and friends are not set.

How about LDFLAGS?

By the way, the build should have succeeded anyway: the "python" executable should be at the root of your build directory.
msg134469 - (view) Author: Paul Griffith (paulg_ca) Date: 2011-04-26 14:17
I found the problem, it is with my system. In the past we used to support SGI hosts and I had the SGI_ABI environmental variable set to -n32.


Please consider this issue closed.
History
Date User Action Args
2011-04-26 14:22:04jceasetresolution: not a bug
2011-04-26 14:17:06paulg_casetstatus: open -> closed

messages: + msg134469
2011-04-26 13:40:25pitrousetmessages: + msg134467
2011-04-26 13:27:24paulg_casetfiles: + config.log

messages: + msg134466
2011-04-26 13:25:51paulg_casetfiles: + typescript.python-2.7.1

messages: + msg134465
2011-04-25 23:02:04jceasetnosy: + jcea
2011-04-25 22:04:44pitrousetnosy: + dmalcolm, pitrou
messages: + msg134424
2011-04-25 20:07:13paulg_cacreate