classification
Title: Test Error
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.2
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Abbaszadeh, r.david.murray
Priority: normal Keywords:

Created on 2011-04-25 11:08 by Abbaszadeh, last changed 2011-04-25 15:34 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
unnamed Abbaszadeh, 2011-04-25 14:57
Messages (4)
msg134377 - (view) Author: Hamid (Abbaszadeh) Date: 2011-04-25 11:08
== CPython 3.2 (r32:88445, Apr 24 2011, 14:27:42) [GCC 4.4.4 20100726 (Red Hat 4.4.4-13)]
==   Linux-2.6.32-71.el6.x86_64-x86_64-with-redhat-6.0-Santiago little-endian
==   /usr/local/src/Python-3.2/build/test_python_2976
Testing with flags: sys.flags(debug=0, division_warning=0, inspect=0, interactive=0, optimize=0, dont_write_bytecode=0, no_user_site=0, no_site=0, ignore_environment=0, verbose=0, bytes_warning=0, quiet=0)
[1/1] test_whatever
test test_whatever crashed -- <class 'ImportError'>: No module named test_whatever
Traceback (most recent call last):
  File "/usr/local/src/Python-3.2/Lib/test/regrtest.py", line 962, in runtest_inner
    the_package = __import__(abstest, globals(), locals(), [])
ImportError: No module named test_whatever
1 test failed:
    test_whatever
msg134383 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2011-04-25 14:06
For the record: yes this is the way regrtest works when a test named on the command line doesn't exist. Not pretty, I'll grant you.  Maybe someone will propose a patch/feature request to improve the error message some day.
msg134389 - (view) Author: Hamid (Abbaszadeh) Date: 2011-04-25 14:57
Dear sir;

I will try to compile python-3.2 in REDHAT EL 6.0. There are a lot of
failure in "make test". How can I fix them?

for example test_import, test_httpserver, ....

Thanks
Abbaszadeh

On Mon, Apr 25, 2011 at 6:36 PM, R. David Murray <report@bugs.python.org>wrote:

>
> R. David Murray <rdmurray@bitdance.com> added the comment:
>
> For the record: yes this is the way regrtest works when a test named on the
> command line doesn't exist. Not pretty, I'll grant you.  Maybe someone will
> propose a patch/feature request to improve the error message some day.
>
> ----------
> nosy: +r.david.murray
> resolution:  -> invalid
> stage:  -> committed/rejected
> type: compile error -> behavior
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue11917>
> _______________________________________
>
msg134391 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2011-04-25 15:34
Your best resources would probably be the python mailing list (python-list, see http://mail.python.org) which is also comp.lang.python, or the #python irc channel on freenode.
History
Date User Action Args
2011-04-25 15:34:00r.david.murraysetmessages: + msg134391
2011-04-25 14:57:13Abbaszadehsetfiles: + unnamed

messages: + msg134389
2011-04-25 14:06:54r.david.murraysetnosy: + r.david.murray
messages: + msg134383
resolution: not a bug

type: compile error -> behavior
stage: resolved
2011-04-25 11:49:20Abbaszadehsetstatus: open -> closed
2011-04-25 11:08:41Abbaszadehcreate