classification
Title: Windows rants& sugestions.
Type: resource usage Stage:
Components: Windows Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: loewis, wolfstar359
Priority: normal Keywords:

Created on 2007-09-22 17:08 by wolfstar359, last changed 2007-09-22 17:19 by loewis. This issue is now closed.

Messages (2)
msg56089 - (view) Author: Michael Lawrence (wolfstar359) Date: 2007-09-22 17:08
TCL Perl , resources , sometimes with the python tool kit , i'd want 
certin compontents removed , 
namely tcl/tk ; on a custom Installer Do you have windows TCL/TK 
(YES/no) (Yes) and the gui option panel to repoiit items add perl ruby 
ponteirs etc.

Alt Python (type) I/E Unix or Cygwin 
ALT perl , Iterix is a real sweet set of tools ,

But mainly Adding Path Statments and getting rid of other Python 
interpriters, and just using main python, 
version'd python is nice but , often force C:\Python 

for windows i just wish you could index other dirs of python code , etc 
and compile them to pyc with a right click option.

some programs use full blown python stubs , anyhow with a path option 
etc , be nice to not have orphaned stubs, etc. 

Juice and others use older python compiler etc, a script to hunt down 
compile > default python = C:\Python\python.exe etc.
also lib paths on python for windows \python\lib-ver keep scripts for 
migration. etc. 
just for sake of argument give upgrade ease and less python25; 25; 26 ; 
30b folders 
and for testing can put the stable into main |python|bin 
beta into |python|testing|bin etc. 

thouse are my few irks with windows , having main tcl path specified is 
resonable because with a utility it is eassy to script-name.tcl > 
filename.dll  , wich offers some speed. 

I dont program to much but , I do try not to have wastes of disk space.
just the option of setting TCL/TK , perl ruby etc for python to call 
from default location would be a plus , and would save some disk space. 
and if the tcl/tk were updated wouldnt break links.
and if 
jsee or just the java  plugin were installed to have system vabiles etc 
for usage. 
PATHEXT add item for executable , can add ruby perl etc to it as well 
for py or pyc, this too would force a default python interpriter, 
option. the curent python for widows is alot faster than the older mini 
ones in other apps. 

anyhow thats my 2 ¢ cents
msg56090 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-09-22 17:19
Unfortunately, I fail to understand what kind of problem you are
reporting. Please report only one issue per bug report, and try
to come up with some title more descriptive than "rants & suggestions".
Please follow this form when reporting bugs, or suggesting improvements:
1. what did you do?
2. what happened?
3. what did you expect to happen instead?

Please try to use full English sentences (ask somebody who knows English
well for help in case you don't speak it well yourself).
History
Date User Action Args
2007-09-22 17:19:28loewissetstatus: open -> closed
resolution: not a bug
messages: + msg56090
nosy: + loewis
2007-09-22 17:08:31wolfstar359create