classification
Title: SGI Irix threads, SunOS lightweight processes, GNU pth threads, Mach C Threads are now unsupported, and code will be removed in 3.3
Type: Stage:
Components: Interpreter Core Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: jcea, vstinner
Priority: normal Keywords:

Created on 2011-04-19 09:45 by vstinner, last changed 2011-04-19 13:13 by vstinner. This issue is now closed.

Messages (3)
msg134029 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-04-19 09:45
Python/thread.c contains the following messages:

#ifdef SGI_THREADS
#error SGI Irix threads are now unsupported, and code will be removed in 3.3.
#include "thread_sgi.h"
#endif


#ifdef SUN_LWP
#error SunOS lightweight processes are now unsupported, and code will be removed in 3.3.
#include "thread_lwp.h"
#endif

#ifdef HAVE_PTH
#error GNU pth threads are now unsupported, and code will be removed in 3.3.
#include "thread_pth.h"
#undef _POSIX_THREADS
#endif

#ifdef C_THREADS
#error Mach C Threads are now unsupported, and code will be removed in 3.3.
#include "thread_cthread.h"
#endif
msg134030 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-04-19 09:55
Oh, the file contains also a reference to a missing file:

#ifdef PLAN9_THREADS
#include "thread_plan9.h"
#endif

But I don't see where PLAN9_THREADS is defined.
msg134050 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-04-19 13:13
Oh, this is a duplicate of #11863.
History
Date User Action Args
2011-04-19 13:13:19vstinnersetstatus: open -> closed
resolution: duplicate
messages: + msg134050
2011-04-19 11:14:30jceasetnosy: + jcea
2011-04-19 09:55:03vstinnersetmessages: + msg134030
2011-04-19 09:45:43vstinnercreate