classification
Title: 2to3 fails with a ParseError
Type: Stage:
Components: 2to3 (2.x to 3.x conversion tool) Versions: Python 3.2, Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, benjamin.peterson, ezio.melotti, vinay.sajip
Priority: normal Keywords:

Created on 2011-04-17 13:12 by vinay.sajip, last changed 2011-04-18 11:18 by amaury.forgeotdarc. This issue is now closed.

Files
File name Uploaded Description Edit
__init__.py vinay.sajip, 2011-04-17 13:12 The file on which 2to3 fails
Messages (2)
msg133922 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2011-04-17 13:12
2to3 fails on boto/rds/__init__.py with a ParseError:

vinay@eta-natty:~/tools/boto$ 2to3 boto/rds/__init__.py 
RefactoringTool: Skipping implicit fixer: buffer
RefactoringTool: Skipping implicit fixer: idioms
RefactoringTool: Skipping implicit fixer: set_literal
RefactoringTool: Skipping implicit fixer: ws_comma
RefactoringTool: Can't parse boto/rds/__init__.py: ParseError: bad input: type=1, value='RDSRegionInfo', context=('\n            ', (48, 12))
RefactoringTool: No files need to be modified.
RefactoringTool: There was 1 error:
RefactoringTool: Can't parse boto/rds/__init__.py: ParseError: bad input: type=1, value='RDSRegionInfo', context=('\n            ', (48, 12))
msg133962 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2011-04-18 11:18
This file has a SyntaxError!
A comma is certainly missing at the end of line 47
History
Date User Action Args
2011-04-18 11:18:27amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg133962

resolution: not a bug
2011-04-17 13:31:33ezio.melottisetnosy: + benjamin.peterson, ezio.melotti
2011-04-17 13:12:15vinay.sajipcreate