classification
Title: reference 2.3 has text that runs past the page
Type: enhancement Stage:
Components: Documentation Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: PDF documentation: long verbatim lines are cut off at right hand side
View: 4173
Assigned To: docs@python Nosy List: Mike.Kamermans, docs@python, ezio.melotti, terry.reedy
Priority: normal Keywords:

Created on 2011-04-17 01:53 by Mike.Kamermans, last changed 2011-04-23 01:43 by terry.reedy. This issue is now closed.

Messages (4)
msg133916 - (view) Author: Mike Kamermans (Mike.Kamermans) Date: 2011-04-17 01:53
page 8 for the python 3.2 refernce document ("identifiers and keywords") has text that runs way past the page. This document (and probably every other document) should be run through LaTeX again with draft, to find all instances where text doesn't fit on the page, so that this can be fixed.
msg134287 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2011-04-23 00:45
I presume you are talking about long boxed grammar or example lines that run horizontally past the right edge of the window, like

id_start     ::=  <all characters in general categories Lu, Ll, Lt, Lm, Lo, Nl, the underscore, and characters with the Other_ID_Start property>

For both the .html (online) and .chm (windows help) versions of the docs, these boxes have horizontal scroll bars. For both types of files, regular text is wrapped according to the size of the window, which the user can change. Neither involved latex and there is no such thing as the width of the page, and there are no page numbers either.

Are you, possibly, referring to a .pdf version, which I believe is run through latex?
msg134288 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2011-04-23 01:23
Yes, the problem is with the PDF. See also #4173.
msg134292 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2011-04-23 01:43
Then this appears to be a duplicate. Closing
History
Date User Action Args
2011-04-23 01:43:33terry.reedysetstatus: open -> closed
resolution: duplicate
superseder: PDF documentation: long verbatim lines are cut off at right hand side
messages: + msg134292
2011-04-23 01:23:09ezio.melottisetmessages: + msg134288
2011-04-23 00:45:12terry.reedysetnosy: + terry.reedy
messages: + msg134287
2011-04-17 11:20:25ezio.melottisetnosy: + ezio.melotti
2011-04-17 01:53:21Mike.Kamermanscreate