classification
Title: smtplib should provide a means to validate a remote server ssl certificate(s)
Type: Stage:
Components: Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: smtplib should support SSL contexts
View: 8809
Assigned To: Nosy List: asdfasdfasdfasdfasdfasdfasdf, pitrou
Priority: normal Keywords:

Created on 2011-04-10 09:24 by asdfasdfasdfasdfasdfasdfasdf, last changed 2011-04-10 09:28 by pitrou. This issue is now closed.

Messages (3)
msg133457 - (view) Author: david (asdfasdfasdfasdfasdfasdfasdf) Date: 2011-04-10 09:24
(This is similar to http://bugs.python.org/issue10274)
The smtplib module should provide a means to validate a remote server ssl certificate(s). 

It would be 'nice' if smtplib.SMTP_SSL & smtplib.starttls took in arguments to validate the remote SMTP's ssl certificate has been signed by a trusted certificate authority(and the common name matches what it should etc.).
msg133458 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-04-10 09:28
Duplicate of issue11821.
msg133459 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2011-04-10 09:28
Oops, I meant issue8809.
History
Date User Action Args
2011-04-10 09:28:38pitrousetsuperseder: smtplib should provide a means to validate a remote server ssl certificate(s) -> smtplib should support SSL contexts
messages: + msg133459
2011-04-10 09:28:38pitrouunlinkissue11821 superseder
2011-04-10 09:28:19pitrousetstatus: open -> closed

nosy: + pitrou
messages: + msg133458

superseder: smtplib should provide a means to validate a remote server ssl certificate(s)
resolution: duplicate
2011-04-10 09:28:19pitroulinkissue11821 superseder
2011-04-10 09:24:28asdfasdfasdfasdfasdfasdfasdfcreate