classification
Title: bytes.hex()
Type: enhancement Stage: resolved
Components: Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder: introduce bytes.hex method (also for bytearray and memoryview)
View: 9951
Assigned To: Nosy List: benjamin.peterson, dtorp, r.david.murray
Priority: normal Keywords:

Created on 2011-04-03 22:02 by dtorp, last changed 2011-04-03 22:35 by r.david.murray. This issue is now closed.

Messages (3)
msg132892 - (view) Author: David Albert Torpey (dtorp) Date: 2011-04-03 22:02
Floats have fromhex() and hex() to round-trip from and to hexadecimal, but bytes only have fromhex(), so it's hard to reliably round-trip.
msg132895 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2011-04-03 22:17
binascci.(un)hexlify
msg132901 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2011-04-03 22:35
Actually, this is a duplicate of issue 9951.
History
Date User Action Args
2011-04-03 22:35:42r.david.murraysetnosy: + r.david.murray
messages: + msg132901
resolution: not a bug -> duplicate

superseder: introduce bytes.hex method (also for bytearray and memoryview)
stage: resolved
2011-04-03 22:17:13benjamin.petersonsetstatus: open -> closed

nosy: + benjamin.peterson
messages: + msg132895

resolution: not a bug
2011-04-03 22:02:19dtorpcreate