classification
Title: test_itimer_real() of test_signal hang on FreeBSD
Type: Stage:
Components: Library (Lib) Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: vstinner
Priority: normal Keywords:

Created on 2011-04-03 19:56 by vstinner, last changed 2011-04-03 22:20 by vstinner. This issue is now closed.

Messages (3)
msg132875 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-04-03 19:56
test_itimer_real() of test_signal hang 30 minutes on FreeBSD "x86 FreeBSD 3.x" and "x86 FreeBSD 7.2 3.x" buildbots. Example:
----------------------------
...
[ 95/354] test_signal
Thread 0x28401040:
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/test_signal.py", line 436 in test_itimer_real
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/case.py", line 387 in _executeTestPart
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/case.py", line 442 in run
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/case.py", line 494 in __call__
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/suite.py", line 105 in run
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/suite.py", line 67 in __call__
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/suite.py", line 105 in run
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/suite.py", line 67 in __call__
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/support.py", line 1078 in run
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/support.py", line 1166 in _run_suite
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/support.py", line 1192 in run_unittest
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/test_signal.py", line 490 in test_main
  File "./Lib/test/regrtest.py", line 1032 in runtest_inner
  File "./Lib/test/regrtest.py", line 826 in runtest
  File "./Lib/test/regrtest.py", line 650 in main
  File "./Lib/test/regrtest.py", line 1607 in <module>
*** Error code 1

Stop in /usr/home/db3l/buildarea/3.x.bolen-freebsd7/build.
program finished with exit code 1
elapsedTime=4160.495190
----------------------------
http://www.python.org/dev/buildbot/all/builders/x86%20FreeBSD%207.2%203.x/builds/1645/steps/test/logs/stdio
http://www.python.org/dev/buildbot/all/builders/x86%20FreeBSD%203.x/builds/1345/steps/test/logs/stdio

I don't know if this issue is new or not, and if it is (or not) related to the new regrtest timeout.

See also issue #11753, another signal issue on FreeBSD.
msg132887 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-04-03 21:21
Ok, this issue is completly related to regrtest.py timeout (issue #11727): test_signal with regrtest.py timeout disabled.
msg132896 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-04-03 22:20
Duplicate of #11753.
History
Date User Action Args
2011-04-03 22:20:59vstinnersetstatus: open -> closed
2011-04-03 22:20:53vstinnersetresolution: duplicate
messages: + msg132896
2011-04-03 21:21:52vstinnersetmessages: + msg132887
2011-04-03 19:56:48vstinnercreate