classification
Title: Python Crash on strftime with %f
Type: crash Stage:
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: strftime('%f') segfault
View: 10762
Assigned To: Nosy List: amaury.forgeotdarc, mangeletti, santoso.wijaya
Priority: normal Keywords:

Created on 2011-04-01 03:12 by mangeletti, last changed 2011-04-01 06:43 by amaury.forgeotdarc. This issue is now closed.

Messages (3)
msg132727 - (view) Author: mangeletti (mangeletti) Date: 2011-04-01 03:12
Win XP 32 bit 2.7.4

>>> import time
>>> time.strftime('%m/%d/%Y %H:%M:%S')
'03/31/2011 20:04:52'
>>> # ^^^ works fine
>>> time.strftime('%m/%d/%Y %H:%M:%S:%f')  # Oops, forgot `time.strftime` doesn't provide microseconds

Python crashes

Error Signature (sorry, didn't get full log):

AppName: python.exe	 AppVer: 0.0.0.0	 ModName: msvcr90.dll
ModVer: 9.0.30729.4148	 Offset: 0005bbac


I've never patched Python, but I might try to give it a whirl.
msg132728 - (view) Author: Santoso Wijaya (santoso.wijaya) * Date: 2011-04-01 06:12
Hm, I can't reproduce this on darwin:

Python 2.7.1 (r271:86832, Jan 26 2011, 19:17:30) 
[GCC 4.2.1 (Apple Inc. build 5664)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import time
>>> time.strftime('%m/%d/%Y %H:%M:%S:%f')
'03/31/2011 23:11:59:f'
msg132731 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2011-04-01 06:43
This is a duplicate of issue10762, and only concerns the Windows C runtime library.
History
Date User Action Args
2011-04-01 06:43:18amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg132731

superseder: strftime('%f') segfault
resolution: duplicate
2011-04-01 06:12:45santoso.wijayasetnosy: + santoso.wijaya
messages: + msg132728
2011-04-01 03:12:58mangeletticreate