classification
Title: Handle ungzipped man pages in rpm builds correctly
Type: behavior Stage:
Components: Distutils Versions: Python 3.0, Python 3.1, Python 2.7, Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: bdist_rpm fails when installing man pages
View: 644744
Assigned To: Nosy List: akitada, dmalcolm, georg.brandl, greenrd, tarek
Priority: normal Keywords: patch

Created on 2005-03-23 15:51 by greenrd, last changed 2009-11-23 02:46 by dmalcolm. This issue is now closed.

Files
File name Uploaded Description Edit
patch greenrd, 2005-03-23 15:51 diff against head
Messages (3)
msg48050 - (view) Author: Robin Green (greenrd) Date: 2005-03-23 15:51
This is on Fedora Core 3.

RPM automatically gzips man pages after the %install
stage. So any generated file lists MUST substitute .gz
filenames for non-.gz filenames for man pages, or the
file check stage that happens just before writing the
RPM out, will fail.

Attached patch is a 'quick hack' using sed, to solve
this issue. Improvements welcome.
msg81560 - (view) Author: Akira Kitada (akitada) * Date: 2009-02-10 16:49
Duplicate of issue644744
msg85549 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-04-05 18:41
Closing this one as duplicate.
History
Date User Action Args
2009-11-23 02:47:00dmalcolmsetnosy: + dmalcolm
2009-04-05 18:41:36georg.brandlsetstatus: open -> closed

nosy: + georg.brandl
messages: + msg85549

superseder: bdist_rpm fails when installing man pages
resolution: duplicate
2009-02-10 16:49:02akitadasetnosy: + akitada
messages: + msg81560
2009-02-10 16:46:27akitadasetnosy: + tarek
type: behavior
versions: + Python 2.6, Python 3.0, Python 3.1, Python 2.7, - Python 2.3
2005-03-23 15:51:30greenrdcreate